Description
Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.
Published: 2026-10-30
Score: 9.1 Critical
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

WordPress Widget Options plugin versions 4.2.5 and older contain a remote code execution flaw. Based on the description, it is inferred that the plugin processes input that an attacker can manipulate, resulting in arbitrary PHP code execution on the server. This violation of the authentication boundary allows an attacker to compromise the confidentiality, integrity, and availability of the affected site.

Affected Systems

The vulnerability affects the Marketing Fire Widget Options plugin shipped with WordPress sites. All installations running any release up to and including 4.2.5 are potentially exposed if the plugin is enabled.

Risk and Exploitability

The CVSS score of 9.1 indicates critical severity, and the attack can be carried out remotely without local access. The EPSS score is not available, but the lack of an existing KEV listing does not reduce the urgency. Based on the description, the likely attack vector involves sending crafted input to a privileged endpoint of the plugin, which can lead to execution of arbitrary PHP code. Prompt patching is therefore essential.

Generated by OpenCVE AI on October 30, 2026 at 19:55 UTC.

Remediation

Vendor Solution

Update to 4.2.6 or a higher version.


OpenCVE Recommended Actions

  • Update the Widget Options plugin to version 4.2.6 or later
  • If an update cannot be applied immediately, deactivate or uninstall the plugin to prevent exploitation until a fix is installed
  • Scan the site for other vulnerable WordPress plugins and apply timely updates to those as well

Generated by OpenCVE AI on October 30, 2026 at 19:55 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 18:45:00 +0000

Type Values Removed Values Added
Description Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.
Title WordPress Widget Options plugin <= 4.2.5 - Remote Code Execution (RCE) vulnerability
Weaknesses CWE-94
References
Metrics cvssV3_1

{'score': 9.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-30T18:30:50.961Z

Reserved: 2026-10-27T00:20:51.129Z

Link: CVE-2026-116852

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-30T19:18:15.020

Modified: 2026-10-30T19:22:27.173

Link: CVE-2026-116852

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T20:00:16Z

Weaknesses
  • CWE-94

    Improper Control of Generation of Code ('Code Injection')