Description
The WP Google Review Slider WordPress plugin before 18.11 does not perform nonce validation when updating its active Google Places configuration, allowing attackers to alter or destroy that configuration via a forged request, provided they can trick a site administrator into following a crafted link.
Published: 2026-11-07
Score: n/a
EPSS: n/a
KEV: No
Impact: Configuration Tampering
Action: Patch
AI Analysis

Impact

The WordPress plugin WP Google Review Slider, prior to version 18.11, does not verify a nonce when an administrator updates the active Google Places configuration. This omission permits an attacker to send a forged request that can modify or delete the Google API settings for the site. The vulnerability enables unauthorized alteration of how the plugin interacts with Google’s API, potentially leading to incorrect display of reviews or disabling the review functionality. The impact is on the integrity of the site’s configuration rather than direct code execution or data exposure.

Affected Systems

The affected product is the WP Google Review Slider WordPress plugin. All installations running any version earlier than 18.11 are vulnerable. There is no vendor name other than the plugin itself, and no other products are mentioned.

Risk and Exploitability

The vulnerability can be exploited via a Cross-Site Request Forgery (CSRF) attack; the attacker must convince a site administrator to click a crafted link or submit a forged form. EPSS data is unavailable and the vulnerability is not listed in CISA KEV, suggesting a modest level of exploitation likelihood. The absence of a CSRF token means the attack requires user interaction, which lowers risk compared to more autonomous exploits. However, because the exposure modifies critical configuration settings, the potential impact to the site’s operation is significant for compromised sites. The CVSS score is not provided, so the severity cannot be quantified precisely from the supplied data.

Generated by OpenCVE AI on November 7, 2026 at 08:10 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the WP Google Review Slider plugin to version 18.11 or newer, which includes proper nonce validation for configuration updates.
  • If no update is immediately possible, remove or disable the plugin to prevent further configuration changes via CSRF.
  • Educate site administrators to avoid clicking suspicious links and to verify the authenticity of URLs before executing actions on the WordPress admin interface.

Generated by OpenCVE AI on November 7, 2026 at 08:10 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 08:30:00 +0000

Type Values Removed Values Added
Weaknesses CWE-352

Sat, 07 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The WP Google Review Slider WordPress plugin before 18.11 does not perform nonce validation when updating its active Google Places configuration, allowing attackers to alter or destroy that configuration via a forged request, provided they can trick a site administrator into following a crafted link.
Title WP Google Review Slider < 18.11 - Google API Settings Update via CSRF
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-07T06:00:24.996Z

Reserved: 2026-10-27T11:54:20.071Z

Link: CVE-2026-117588

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-07T06:16:57.037

Modified: 2026-11-07T06:16:57.037

Link: CVE-2026-117588

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T08:15:03Z

Weaknesses
  • CWE-352

    Cross-Site Request Forgery (CSRF)