Description
The Falang multilanguage for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'falang_term[<taxonomy>][<locale>][<field>] (via order[] driving wp_update_term)' parameter in all versions up to, and including, 1.4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is made reliable because the required 'falang' nonce is disclosed to any logged-in user through the equally unprotected wp_ajax_falang_menu_translation handler, requiring no elevated access to obtain.
Published: 2026-11-07
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The Falang multilanguage plugin for WordPress is vulnerable to a stored cross‑site scripting flaw that occurs when the plugin accepts input for the falang_term parameter without proper sanitization or escaping before it is stored and later rendered. An attacker who can log into the site with subscriber‑level or higher privileges can inject arbitrary JavaScript into these parameters. The injected script is persisted in the database and will execute for any user who views the affected page, enabling session hijacking, defacement, or data theft. The weakness corresponds to a classic input‑validation XSS flaw (CWE‑79). The exploit requires only an authenticated user, and the required nonce is publicly visible to any logged‑in user, making the attack trivial for any identity that can log in.

Affected Systems

The vulnerability affects all installations of the Falang multilanguage plugin with version 1.4.6 or earlier. The affected component is the Falang plugin for WordPress, coded by sbouey. Administrators should identify sites running this plugin and verify the installed version.

Risk and Exploitability

The CVSS base score for this flaw is 6.4, indicating moderate‑to‑high severity. The EPSS score is not reported, so the current exploitation probability is unknown but the vulnerability can be easily discovered by anyone logged in. In addition, the flaw is not listed in the CISA KEV catalog, meaning there is no publicly known exploited proof‑of‑concept code in circulation. The hook revealing the form nonce is unprotected, so an attacker can obtain it through a normal authenticated request, reducing the effort needed. Because the attack requires only a subscriber account, the potential for widespread compromise is significant, especially on sites with many active users.

Generated by OpenCVE AI on November 7, 2026 at 12:29 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Falang to the latest version (>=1.4.7) to remove the stored XSS vulnerability.
  • If an upgrade is not possible, disable or delete the Falang plugin to prevent exploitation.
  • Implement a web application firewall or XSS filtering rules targeting the falang_term parameter to block malicious payloads.
  • Consider restricting subscriber roles or reducing capabilities to mitigate the low‑privilege attacker window.

Generated by OpenCVE AI on November 7, 2026 at 12:29 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Falang multilanguage for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'falang_term[<taxonomy>][<locale>][<field>] (via order[] driving wp_update_term)' parameter in all versions up to, and including, 1.4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is made reliable because the required 'falang' nonce is disclosed to any logged-in user through the equally unprotected wp_ajax_falang_menu_translation handler, requiring no elevated access to obtain.
Title Falang multilanguage for WordPress <= 1.4.6 - Authenticated (Subscriber+) Stored Cross-Site Scripting via falang_term[] via `falang_language_ordering` AJAX / `edit_term` hook
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T18:06:01.884Z

Reserved: 2026-10-27T15:16:13.282Z

Link: CVE-2026-118047

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T12:17:43.230

Modified: 2026-11-07T18:17:13.030

Link: CVE-2026-118047

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T12:30:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')