Description
The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Simple Form autocomplete lookup label in versions up to, and including, 5.5.89 This is due to insufficient output escaping on the value returned by WPDA_Autocomplete::autocomplete_lookup() when it is emitted into a single-quoted HTML attribute by WPDA_Simple_Form_Item_Autocomplete::show_item() (the escape-output lint is explicitly suppressed on the echo line). This makes it possible for authenticated attackers, with Subscriber-level access and above, who are permitted to edit a lookup row through a legacy Form, to inject arbitrary web scripts in pages that will execute whenever a user — including a higher-privileged user editing a linked record that uses the autocomplete relationship — accesses the injected page.
Published: 2026-11-07
Score: 6.4 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored XSS
Action: Upgrade
AI Analysis

Impact

The vulnerability is a stored cross‑site scripting flaw exposed through the Simple Form autocomplete lookup label in WP Data Access. Insufficient output escaping allows an authenticated user at the Subscriber level or higher to inject arbitrary scripts that are saved as part of a lookup row. When any user, including administrators editing a related record, loads a page containing the injected label, the malicious code executes in the context of that user, potentially allowing session hijacking, credential theft, or defacement.

Affected Systems

This issue affects the WordPress plugin WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps, specifically versions ranging from the initial release up to and including 5.5.89. The problem originates in the file WPDA_Simple_Form_Item_Autocomplete::show_item() which echoes the lookup value without proper escaping.

Risk and Exploitability

The CVSS score of 6.4 indicates moderate severity. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog, suggesting no widespread public exploitation has been reported. Attack requires authentication with at least Subscriber privileges; the attacker must edit a legacy form to insert malicious markup. Once the payload is stored, it is triggered automatically on any page that renders the lookup label, exposing higher‑privileged users to the risk of script execution.

Generated by OpenCVE AI on November 7, 2026 at 08:03 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade WP Data Access to version 5.5.90 or later where the autocomplete lookup value is properly escaped.
  • If an upgrade cannot be performed immediately, limit or revoke Subscriber‑level edit permissions for lookup rows in legacy forms so that only trusted administrators can modify them.
  • As a temporary workaround, sanitize user input for autocomplete lookup labels or employ a security plugin that blocks XSS in output.

Generated by OpenCVE AI on November 7, 2026 at 08:03 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 06:45:00 +0000

Type Values Removed Values Added
Description The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Simple Form autocomplete lookup label in versions up to, and including, 5.5.89 This is due to insufficient output escaping on the value returned by WPDA_Autocomplete::autocomplete_lookup() when it is emitted into a single-quoted HTML attribute by WPDA_Simple_Form_Item_Autocomplete::show_item() (the escape-output lint is explicitly suppressed on the echo line). This makes it possible for authenticated attackers, with Subscriber-level access and above, who are permitted to edit a lookup row through a legacy Form, to inject arbitrary web scripts in pages that will execute whenever a user — including a higher-privileged user editing a linked record that uses the autocomplete relationship — accesses the injected page.
Title WP Data Access <= 5.5.89 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Autocomplete Lookup Label
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T06:39:35.490Z

Reserved: 2026-10-27T15:17:13.676Z

Link: CVE-2026-118048

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T07:17:02.923

Modified: 2026-11-07T07:17:03.047

Link: CVE-2026-118048

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T08:15:03Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')