Description
The Image Hover Effects Ultimate ( Image Gallery, Effects, Lightbox, Comparison & Magnifier ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'rawdata.oxi_image_comparison_before_text' parameter in all versions up to, and including, 9.12.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when an administrator has configured the plugin's "Who can edit" setting to Subscriber, which allows any authenticated user to overwrite existing styles — including those created by administrators — via a missing ownership check on the target style ID.
Published: 2026-11-07
Score: 4.9 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Apply Patch
AI Analysis

Impact

The vulnerability is a stored cross‑site scripting flaw in the Image Hover Effects Ultimate WordPress plugin, enabled via the rawdata.oxi_image_comparison_before_text parameter. Authenticated users with subscriber or higher privileges can inject arbitrary scripts because input is not sanitized or escaped. Those scripts run whenever a page containing the injected content is viewed, allowing malicious code execution in the context of the site and potentially affecting other authenticated users.

Affected Systems

The affected product is the Image Hover Effects Ultimate plugin by oxilab, for WordPress sites. All releases up to and including version 9.12.2 are affected whenever the plugin’s Who can edit option permits subscriber‑level users to edit styles.

Risk and Exploitability

The CVSS score is 4.9, indicating moderate risk. The EPSS score is unavailable, and the vulnerability is not in CISA KEV. Because it requires authenticated subscribers and depends on the plugin configuration, the attack surface is limited to sites where the editor role has been set to allow subscriber edits. If exploited, attackers can insert scripts that execute in the browser of any visitor to the affected page, which may lead to defacement, data theft, or credential theft. The lack of a known public exploit means the likelihood is low, but the impact to affected users warrants timely remediation.

Generated by OpenCVE AI on November 7, 2026 at 12:28 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Image Hover Effects Ultimate to a version newer than 9.12.2, where the stored XSS issue has been addressed.
  • Reconfigure the plugin’s editor permissions, setting "Who can edit" to Administrator only, to prevent subscribers from overwriting styles.
  • Review and sanitize any existing content that may contain injected scripts, for example by deleting or editing styles and comparison text settings.

Generated by OpenCVE AI on November 7, 2026 at 12:28 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Image Hover Effects Ultimate ( Image Gallery, Effects, Lightbox, Comparison & Magnifier ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'rawdata.oxi_image_comparison_before_text' parameter in all versions up to, and including, 9.12.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when an administrator has configured the plugin's "Who can edit" setting to Subscriber, which allows any authenticated user to overwrite existing styles — including those created by administrators — via a missing ownership check on the target style ID.
Title Image Hover Effects Ultimate ( Image Gallery, Effects, Lightbox, Comparison & Magnifier ) <= 9.12.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'oxi_image_comparison_before_text' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 4.9, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T18:06:01.671Z

Reserved: 2026-10-27T15:28:10.709Z

Link: CVE-2026-118056

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T12:17:43.563

Modified: 2026-11-07T18:17:13.510

Link: CVE-2026-118056

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T12:30:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')