Impact
A PHP Object Injection flaw exists in the Frisbii Pay WordPress plugin up to version 1.8.19, allowing an attacker to craft serialized input that is unserialized by the plugin. The vulnerability is rooted in improper handling of serialized data, categorized as CWE‑502. Exploitation can lead to execution of arbitrary code within the WordPress environment, thereby compromising the confidentiality, integrity, and availability of the site and its data.
Affected Systems
The Frisbii Pay plugin, produced by Frisbii, is affected. Any WordPress installation that has installed Frisbii Pay version 1.8.19 or earlier is vulnerable. The flaw is remedied by upgrading to 1.8.20 or later, which removes the insecure unserialization code.
Risk and Exploitability
The CVSS score of 8.8 reflects a high severity level. While the EPSS score is not available, the lack of inclusion in the CISA KEV catalog does not lessen the risk. The attack vector is inferred to be the plugin’s publicly exposed endpoints that accept serialized payloads; a crafted request would trigger the unserialize call and enable code execution on the server.
OpenCVE Enrichment