Description
Unauthenticated Cross Site Scripting (XSS) in GlobalPayments WooCommerce <= 1.23.3 versions.
Published: 2026-10-29
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Cross Site Scripting
Action: Patch Now
AI Analysis

Impact

Unauthenticated Cross Site Scripting (XSS) is present in GlobalPayments WooCommerce plugin versions 1.23.3 and earlier. The flaw allows an attacker to inject arbitrary JavaScript into the plugin pages, which is executed in the browser of any user who views the affected content. This can lead to session hijacking, credential theft, or defacement of the site. The weakness is a classic reflected input sanitization issue identified as CWE-79.

Affected Systems

Vendors affected are Global Payments, specifically the GlobalPayments WooCommerce WordPress plugin. The vulnerability applies to all releases up to and including version 1.23.3. Users running these versions should verify the installed plugin version against this list.

Risk and Exploitability

The CVSS score of 7.1 indicates a medium to high severity. Because EPSS data is unavailable and the vulnerability is not in the CISA KEV catalog, the known exploitation risk is moderate but could be higher if attackers focus on WordPress sites utilizing this plugin. The attack vector is inferred to be web-based and unauthenticated, as the description states that no authentication is required to trigger the XSS. An attacker could exploit the flaw simply by visiting a maliciously crafted URL or by embedding payloads in data processed by the plugin.

Generated by OpenCVE AI on October 29, 2026 at 17:16 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the GlobalPayments WooCommerce plugin to the latest version that does not contain the XSS flaw, preferably version 1.23.4 or newer.
  • If an update is not immediately possible, remove or disable the plugin to eliminate the attack surface until a fix is applied.
  • Review all other WordPress plugins for similar input sanitization weaknesses and apply the latest security patches.
  • Consider enabling web application firewall rules that block suspicious JavaScript payloads or implement a content security policy to mitigate manual XSS exploitation.

Generated by OpenCVE AI on October 29, 2026 at 17:16 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Description Unauthenticated Cross Site Scripting (XSS) in GlobalPayments WooCommerce <= 1.23.3 versions.
Title WordPress GlobalPayments WooCommerce plugin <= 1.23.3 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T15:23:57.104Z

Reserved: 2026-10-27T16:00:44.817Z

Link: CVE-2026-118085

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-29T16:18:03.577

Modified: 2026-10-29T16:20:19.663

Link: CVE-2026-118085

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T17:30:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')