Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Igor Funa Ad Inserter ad-inserter allows Stored XSS.This issue affects Ad Inserter: from n/a through 2.8.18.
Published: 2026-10-29
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored XSS via Ad Inserter plugin
Action: Patch
AI Analysis

Impact

Ad Inserter, a WordPress plugin by Igor Funa, contains an improper neutralization of input during web page generation that enables stored cross‑site scripting. The flaw allows an attacker to inject malicious scripts that are executed in the browsers of all site visitors, potentially exposing session data, defacing content, or redirecting traffic. The weakness is categorized as CWE‑79, a classic input validation failure.

Affected Systems

All installations of the Ad Inserter WordPress plugin up through version 2.8.18 are vulnerable, regardless of any custom configuration. No later version is affected.

Risk and Exploitability

The vulnerability scores a CVSS of 6.5, indicating moderate severity. The EPSS score is not available, and the issue is not listed in CISA’s KEV catalog, suggesting limited evidence of exploitation to date. Attackers would need the ability to write or modify content in the plugin’s settings—typically via an administrative WordPress account—to implant the malicious script. Once stored, the payload executes for every user who views pages that include the plugin's output.

Generated by OpenCVE AI on October 29, 2026 at 15:25 UTC.

Remediation

Vendor Solution

Update the WordPress Ad Inserter plugin to the latest available version (at least 2.8.19).


OpenCVE Recommended Actions

  • Update the Ad Inserter plugin to version 2.8.19 or newer to remove the stored XSS flaw.
  • If an immediate update is not possible, disable or tightly restrict the plugin’s content‑insertion feature to trusted administrators only.
  • Apply a web application firewall and enforce a strict Content Security Policy to mitigate the impact of any remaining XSS vectors and to limit script execution.
  • Consider removing the Ad Inserter plugin altogether if it is not essential to site functionality.

Generated by OpenCVE AI on October 29, 2026 at 15:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 29 Oct 2026 15:00:00 +0000

Type Values Removed Values Added
First Time appeared Igorfuna
Igorfuna ad Inserter
Wordpress-extensions
Wordpress-extensions ad Inserter
Vendors & Products Igorfuna
Igorfuna ad Inserter
Wordpress-extensions
Wordpress-extensions ad Inserter

Thu, 29 Oct 2026 14:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Thu, 29 Oct 2026 13:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Igor Funa Ad Inserter ad-inserter allows Stored XSS.This issue affects Ad Inserter: from n/a through 2.8.18.
Title WordPress Ad Inserter plugin <= 2.8.18 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

Igorfuna Ad Inserter
Wordpress-extensions Ad Inserter
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-29T13:47:36.720Z

Reserved: 2026-10-27T16:00:44.818Z

Link: CVE-2026-118094

cve-icon Vulnrichment

Updated: 2026-10-29T13:45:44.946Z

cve-icon NVD

Status : Deferred

Published: 2026-10-29T13:17:08.857

Modified: 2026-10-29T14:56:26.107

Link: CVE-2026-118094

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-29T15:30:16Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')