Description
The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'repeater[*][version_uid] (and many sibling fields: freeze-mode, cookie-input, ip-input, compare, utm-value, page-url-compare, group-name, custom, …)' parameter in all versions up to, and including, 1.10.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-28
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting via authenticated contributor access
Action: Immediate Patch
AI Analysis

Impact

The If‑So Dynamic Content plugin contains a stored cross‑site scripting vulnerability that is triggered through the "repeater" parameter family, including fields such as version_uid and other sibling attributes. The plugin fails to sanitize input or escape output for these fields, allowing an attacker who can log in with contributor or higher privileges to inject arbitrary JavaScript that will be persisted in the database and executed whenever an affected page is viewed. This flaw could lead to session hijacking, defacement, or the execution of further malicious code by downstream visitors.

Affected Systems

The vulnerability affects the If‑So Dynamic Content – Elementor & All Page Builders Personalization WordPress plugin in all versions up to and including 1.10.2. All installations that rely on this plugin and permit contributor‑level access are at risk.

Risk and Exploitability

With a CVSS score of 6.4, the flaw represents a medium‑severity risk. The exploit probability is not quantified by EPSS, and the vulnerability is not listed in CISA’s KEV catalog. The likely attack vector is that an authenticated attacker, using a contributor or higher role, submits malicious input through the plugin’s UI, which is then stored and later rendered as part of a page. Once exploited, the attacker can perform whatever actions the compromised user can, including cookie theft and session fixation, which may extend to higher‑privilege accounts through social engineering or follow‑on exploits.

Generated by OpenCVE AI on October 28, 2026 at 09:07 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the If‑So plugin to the latest released version that fixes the stored XSS issue.
  • If an update is not immediately available, disable the plugin or uninstall it to eliminate the risk.
  • Restrict contributor and higher roles from accessing the plugin’s settings, or roll back the permissions to a minimal level that does not allow modification of the repeater fields.

Generated by OpenCVE AI on October 28, 2026 at 09:07 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 07:00:00 +0000

Type Values Removed Values Added
Description The If-So Dynamic Content – Elementor & All Page Builders Personalization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'repeater[*][version_uid] (and many sibling fields: freeze-mode, cookie-input, ip-input, compare, utm-value, page-url-compare, group-name, custom, …)' parameter in all versions up to, and including, 1.10.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title If-So Dynamic Content <= 1.10.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'repeater' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T06:45:12.978Z

Reserved: 2026-10-27T17:38:57.042Z

Link: CVE-2026-118164

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-28T07:16:48.050

Modified: 2026-10-28T07:16:48.050

Link: CVE-2026-118164

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T09:15:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')