Description
The Page and Post Restriction plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 1.6.1 This is due to the `papr_restrict_page_post_rest_api()` function, hooked on `rest_pre_dispatch`, re-authenticating the current user from the `wordpress_logged_in` cookie via `wp_set_current_user()` for any GET or HEAD REST request where the current user is 0, without verifying a REST nonce — silently undoing the nonce-zeroing that WordPress core's `rest_cookie_check_errors()` performs on cookie-authenticated requests that lack an `X-WP-Nonce` header or `_wpnonce` parameter. Combined with WordPress's permissive REST CORS behavior — which echoes the request `Origin` and sets `Access-Control-Allow-Credentials: true` — this allows an unauthenticated attacker to read REST API GET responses as a logged-in victim, exposing role-restricted and private post/page content, victim user profile data via `/wp-json/wp/v2/users/me`, and comments the victim is authorized to see. This requires the attacker to lure a logged-in user into visiting an attacker-controlled page that issues credentialed cross-origin `fetch` requests against the target site's REST API; no nonce or further victim interaction beyond the page visit is needed.
Published: 2026-10-30
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized Data Exposure
Action: Update Plugin
AI Analysis

Impact

The vulnerability is an authentication bypass caused by the plugin’s REST API handler re‑authenticating a visitor with a valid `wordpress_logged_in` cookie without requiring a REST nonce. This silently restores the user’s session and defeats WordPress core’s nonce zeroing for cookie‑authenticated requests. As a result an unauthenticated attacker can read role‑restricted content, private posts, user profile data through `/wp-json/wp/v2/users/me`, and any comments the victim is allowed to see, simply by having the victim’s browser make a cross‑origin REST GET request.

Affected Systems

The flaw exists in the WordPress plugin Page and Post Restriction, developed by cyberlord92, for all releases up to and including version 1.6.1. No newer release information is listed in the data, and the vulnerability was discovered in the plugin’s handling of REST API calls. The affected environment is a WordPress site running this plugin with standard cookie authentication.

Risk and Exploitability

The CVSS score of 6.5 indicates moderate severity. EPSS data is unavailable, so the exploitation probability is uncertain, and the vulnerability is not listed in the CISA KEV catalog. Exploitation requires the attacker to lure a logged‑in user to a malicious page that issues credentialed fetch requests to the site’s REST API, taking advantage of WordPress’s permissive CORS that echoes the request Origin and allows `Access‑Control‑Allow‑Credentials`. No further victim interaction is needed beyond visiting the page.

Generated by OpenCVE AI on October 30, 2026 at 06:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Page and Post Restriction plugin to a version newer than 1.6.1 once a fix is available.
  • If an upgrade is not immediately feasible, temporarily disable or remove the plugin from the site.
  • Configure the server or WordPress settings to block or restrict cross‑origin requests to the REST API by removing or tightening the permissive CORS headers (`Access‑Control‑Allow‑Credentials`).
  • Keep WordPress core and all other plugins up to date to minimize overall exposure.

Generated by OpenCVE AI on October 30, 2026 at 06:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Page and Post Restriction plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 1.6.1 This is due to the `papr_restrict_page_post_rest_api()` function, hooked on `rest_pre_dispatch`, re-authenticating the current user from the `wordpress_logged_in` cookie via `wp_set_current_user()` for any GET or HEAD REST request where the current user is 0, without verifying a REST nonce — silently undoing the nonce-zeroing that WordPress core's `rest_cookie_check_errors()` performs on cookie-authenticated requests that lack an `X-WP-Nonce` header or `_wpnonce` parameter. Combined with WordPress's permissive REST CORS behavior — which echoes the request `Origin` and sets `Access-Control-Allow-Credentials: true` — this allows an unauthenticated attacker to read REST API GET responses as a logged-in victim, exposing role-restricted and private post/page content, victim user profile data via `/wp-json/wp/v2/users/me`, and comments the victim is authorized to see. This requires the attacker to lure a logged-in user into visiting an attacker-controlled page that issues credentialed cross-origin `fetch` requests against the target site's REST API; no nonce or further victim interaction beyond the page visit is needed.
Title Page and Post Restriction <= 1.6.1 - Unauthenticated Authentication Bypass via REST API Nonce Bypass via Cookie Re-Authentication
Weaknesses CWE-287
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T05:35:50.445Z

Reserved: 2026-10-27T18:59:48.641Z

Link: CVE-2026-118194

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T06:16:47.230

Modified: 2026-10-30T06:16:47.230

Link: CVE-2026-118194

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T07:00:16Z

Weaknesses