Description
The Essential Addons for Elementor – Popular Elementor Templates & Widgets plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.8.7 via the `page_id` parameter of the `register_user()` function. The vulnerability exists because the handler's post status deny-list rejects `future`, `draft`, and `pending` but admits `inherit` — the status carried by every WordPress revision — allowing an attacker to substitute a revision ID for a live page ID, while a flawed "last saved by administrator" check reads `post_author` on revisions (which reflects the editing administrator) rather than the `_edit_last` meta that is never copied to revisions, and the nonce gate is rendered ineffective because any unauthenticated visitor can freely obtain a valid nonce via the `wp_ajax_nopriv_eael_get_token` endpoint. This makes it possible for unauthenticated attackers to register an account with a role as high as Editor — gaining capabilities including `edit_others_posts`, `publish_pages`, `upload_files`, and `unfiltered_html` — by naming a revision whose `_elementor_data` contains an elevated role an administrator previously saved and later reverted on a page bearing the Login/Register widget. Successful exploitation requires that the site has "Anyone can register" enabled and that an administrator has at some point saved and then reverted a non-default "New User Role" on an affected page.
Published: 2026-10-30
Score: 7.4 High
EPSS: n/a
KEV: No
Impact: Unauthenticated Privilege Escalation
Action: Patch Immediately
AI Analysis

Impact

The Essential Addons for Elementor plugin contains a flaw in its user registration logic that allows an attacker to pass a revision ID as the target page ID. Because the revision post status "inherit" is not filtered out, and the code mistakenly uses the revision's "post_author" field instead of the "_edit_last" meta field, the system treats the revision as if it were edited by an administrator. This bypasses standard ACL checks and, coupled with an ineffective nonce that can be obtained by any visitor, lets an unauthenticated user create an account with editor permissions, giving them edit_others_posts, publish_pages, upload_files, and unfiltered_html rights. The weakness is a classic example of improper authorization (CWE-269).

Affected Systems

Any WordPress site that has the Essential Addons for Elementor plugin installed on a version 6.8.7 or earlier, and that has the "Anyone can register" setting enabled. The vulnerability also requires that an administrator has previously used the Login/Register widget to assign a non‑default user role to a page and then reverted the setting, so that the role information is stored in a page revision. If these conditions are met, the exploit can be executed on the affected installation regardless of the site’s overall configuration.

Risk and Exploitability

The score of 7.4 indicates a high severity assessment. Although an EPSS value is not available, the lack of a KEV listing suggests that the vulnerability has not yet been widely exploited in the wild, but the attack vector is simple: a web request can retrieve a valid nonce via the wp_ajax_nopriv_eael_get_token endpoint, and then the attacker can trigger the register_user() function with a crafted payload. Given the widespread use of the plugin and the common configuration of allowing public registration, the risk of exploitation remains significant for administrators who have not applied the vendor’s patch.

Generated by OpenCVE AI on October 30, 2026 at 18:39 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Essential Addons for Elementor plugin to version 6.8.8 or later, which removes the unauthenticated privilege escalation path.
  • Disable the "Anyone can register" setting in WordPress to prevent unauthenticated account creation.
  • Remove or disable the Login/Register widget from pages that have previously stored a custom new‑user role, or reset the widget’s user role configuration to the default "Subscriber" role.

Generated by OpenCVE AI on October 30, 2026 at 18:39 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 22:45:00 +0000

Type Values Removed Values Added
First Time appeared Wordpress-extensions
Wordpress-extensions essential Addons For Elementor
Wpdevteam
Wpdevteam essential Addons For Elementor
Vendors & Products Wordpress-extensions
Wordpress-extensions essential Addons For Elementor
Wpdevteam
Wpdevteam essential Addons For Elementor

Fri, 30 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The Essential Addons for Elementor – Popular Elementor Templates & Widgets plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.8.7 via the `page_id` parameter of the `register_user()` function. The vulnerability exists because the handler's post status deny-list rejects `future`, `draft`, and `pending` but admits `inherit` — the status carried by every WordPress revision — allowing an attacker to substitute a revision ID for a live page ID, while a flawed "last saved by administrator" check reads `post_author` on revisions (which reflects the editing administrator) rather than the `_edit_last` meta that is never copied to revisions, and the nonce gate is rendered ineffective because any unauthenticated visitor can freely obtain a valid nonce via the `wp_ajax_nopriv_eael_get_token` endpoint. This makes it possible for unauthenticated attackers to register an account with a role as high as Editor — gaining capabilities including `edit_others_posts`, `publish_pages`, `upload_files`, and `unfiltered_html` — by naming a revision whose `_elementor_data` contains an elevated role an administrator previously saved and later reverted on a page bearing the Login/Register widget. Successful exploitation requires that the site has "Anyone can register" enabled and that an administrator has at some point saved and then reverted a non-default "New User Role" on an affected page.
Title Essential Addons for Elementor <= 6.8.7 - Unauthenticated Privilege Escalation to 'page_id' Parameter via Elementor Revision
Weaknesses CWE-269
References
Metrics cvssV3_1

{'score': 7.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N'}


Subscriptions

Wordpress-extensions Essential Addons For Elementor
Wpdevteam Essential Addons For Elementor
cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T18:08:57.942Z

Reserved: 2026-10-27T19:08:29.796Z

Link: CVE-2026-118205

cve-icon Vulnrichment

Updated: 2026-10-30T18:01:43.283Z

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:17:24.253

Modified: 2026-10-30T19:18:17.903

Link: CVE-2026-118205

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T22:30:13Z

Weaknesses
  • CWE-269

    Improper Privilege Management