Description
Incorrect Authorization vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Authorization Bypass (Forceful Browsing)
Action: Immediate Upgrade
AI Analysis

Impact

The Drupal Commerce Core component contains an incorrect Authorization flaw that permits attackers to perform forceful browsing. This flaw allows an unauthenticated user or a user without appropriate permissions to request URLs that belong to a merchant or administrator area, thereby exposing confidential merchant data and product information. The underlying weakness is a misimplementation of ACL enforcement (CWE‑863).

Affected Systems

The vulnerability affects Drupal Commerce Core versions 0.0.0 through 2.41.0 and 3.0.0 through 3.3.13. These versions are distributed by the Drupal community and are commonly deployed in e‑commerce websites using Drupal.

Risk and Exploitability

As the CVSS score is not publicly disclosed, it is difficult to quantify the severity numerically. The exploitability appears low to moderate because it requires knowledge of merchant URLs. Since no public exploitation has been reported and the vulnerability is not listed in CISA KEV, the likelihood of an immediate widespread attack is low. However, the risk to merchant confidentiality remains significant for sites running the affected version stack. The attack vector is inferred to be remote over the web, leveraging the ability to request disallowed URLs.

Generated by OpenCVE AI on October 30, 2026 at 04:59 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Drupal Commerce Core to a release version that is not affected (versions greater than 2.41.0 or 3.3.13).
  • Reconfigure the ACLs for the back‑office and merchant endpoints to enforce proper authorization checks.
  • Conduct a review of all exposed URLs to ensure no merchant resources can be accessed without authentication, and adjust routing or module settings accordingly.

Generated by OpenCVE AI on October 30, 2026 at 04:59 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
First Time appeared Drupal
Drupal commerce Core
Vendors & Products Drupal
Drupal commerce Core

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Incorrect Authorization vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.
Title Commerce Core - Less critical - Access bypass - SA-CONTRIB-2026-256
Weaknesses CWE-863
References

Subscriptions

Drupal Commerce Core
cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:11.899Z

Reserved: 2026-10-28T15:50:46.717Z

Link: CVE-2026-118541

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:19.100

Modified: 2026-10-30T04:18:19.100

Link: CVE-2026-118541

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T05:30:09Z

Weaknesses