Description
Exposure of Sensitive Information Through Data Queries vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.
Published: 2026-10-30
Score: n/a
EPSS: n/a
KEV: No
Impact: Information Disclosure
Action: Patch
AI Analysis

Impact

The vulnerability in Drupal Commerce Core allows attackers to forcefully browse sensitive data through improper handling of data queries. An unauthenticated user could construct requests that reveal protected information, potentially exposing customer details or private operational data. The flaw is a classic information disclosure weakness that can compromise confidentiality without altering system integrity or availability.

Affected Systems

Drupal Commerce Core products are affected. Versions from 0.0.0 through 2.41.0 and from 3.0.0 through 3.3.13 are vulnerable. These encompass both early development builds and stable releases within that range. Users running any of these versions should verify the install and consider remediation.

Risk and Exploitability

The exploit path requires basic web access to the Commerce Core instance and the ability to manipulate query parameters. There is no indication of remote code execution or privileged escalation; the risk is purely data exposure. The EPSS score is unavailable, and the vulnerability is not listed in CISA’s KEV catalog, suggesting limited documented exploitation. However, the moderate severity indicates a non‑trivial threat to confidentiality that warrants attention.

Generated by OpenCVE AI on October 30, 2026 at 05:00 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update Drupal Commerce Core to a version newer than 2.41.0 or newer than 3.3.13 to eliminate the underlying code that permits forceful browsing
  • Reconfigure access control for Commerce entities to ensure that only authorized roles can view sensitive data and that query parameters are sanitized
  • Audit custom code that interfaces with Commerce Core, particularly any modules that extend data queries, to enforce the same access restrictions and guard against indirect disclosure

Generated by OpenCVE AI on October 30, 2026 at 05:00 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

References
History

Fri, 30 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
First Time appeared Drupal
Drupal commerce Core
Vendors & Products Drupal
Drupal commerce Core

Fri, 30 Oct 2026 03:30:00 +0000

Type Values Removed Values Added
Description Exposure of Sensitive Information Through Data Queries vulnerability in Drupal Commerce Core allows Forceful Browsing. This issue affects Commerce Core versions: from 0.0.0 to 2.41.0, from 3.0.0 to 3.3.13.
Title Commerce Core - Moderately critical - Information disclosure - SA-CONTRIB-2026-259
Weaknesses CWE-202
References

Subscriptions

Drupal Commerce Core
cve-icon MITRE

Status: PUBLISHED

Assigner: drupal

Published:

Updated: 2026-10-30T03:09:08.731Z

Reserved: 2026-10-28T15:50:46.717Z

Link: CVE-2026-118544

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T04:18:19.533

Modified: 2026-10-30T04:18:19.533

Link: CVE-2026-118544

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T05:30:09Z

Weaknesses
  • CWE-202

    Exposure of Sensitive Information Through Data Queries