Description
The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'width' parameter in all versions up to, and including, 3.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-10-30
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The Events Made Easy WordPress plugin contains a stored cross‑site scripting flaw that is triggered by the unsanitized 'width' attribute in its shortcode. The flaw allows an authenticated user with contributor-level permissions or higher to inject arbitrary JavaScript into the site’s content. Once injected scripts are executed in the browsers of any visitor who loads the affected page, a malicious actor can hijack user sessions, steal credentials, deface content, or load additional malware. This vulnerability is assigned to CWE‑79.

Affected Systems

This issue affects all releases of the Events Made Easy plugin by liedekef through version 3.3.1, inclusive. WordPress sites that have not updated to a fixed version beyond 3.3.1 are potentially vulnerable. The plugin is commonly found on community, corporate, and event‑management WordPress installations that use the Events Made Easy shortcode for displaying event information.

Risk and Exploitability

The flaw carries a CVSS score of 6.4, indicating a moderate severity. Because the attacker must be authenticated at the contributor level, the exploitation window is limited to sites with poorly managed roles, but once access is obtained the impact is significant. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog, yet the potential for widespread XSS attacks on multiple visitors makes it a high‑priority concern for any site that needs to be patched promptly.

Generated by OpenCVE AI on October 30, 2026 at 06:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Events Made Easy plugin to the latest release that properly sanitizes the width attribute.
  • Remove or rewrite any content that contains malicious scripts if an immediate update is not possible.
  • Revoke Contributor role from users who do not require it or modify role capabilities to prevent shortcode editing.
  • Audit the site for other stored XSS vectors and apply input sanitization or escaping where necessary.

Generated by OpenCVE AI on October 30, 2026 at 06:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Events Made Easy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'width' parameter in all versions up to, and including, 3.3.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Events Made Easy <= 3.3.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'width' Shortcode Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T05:35:51.705Z

Reserved: 2026-10-28T17:16:08.610Z

Link: CVE-2026-118634

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T06:16:47.870

Modified: 2026-10-30T06:16:47.870

Link: CVE-2026-118634

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T06:30:09Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')