Description
The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
Published: 2026-11-06
Score: n/a
EPSS: n/a
KEV: No
Impact: Privilege Escalation
Action: Immediate Patch
AI Analysis

Impact

The Surfer WordPress plugin version before 1.8.1.759 reveals a sensitive API credential to users with only contributor permissions through the post editor interface. The same credential is the exclusive gatekeeper for a set of privileged REST API functions, enabling a contributor to access and execute actions typically reserved for higher‑level roles. This flaw allows an attacker who can log in as a contributor to read the API key and then leverage it to create, modify, or publish arbitrary content, effectively escalating privileges within the WordPress site.

Affected Systems

All installations of the Surfer plugin running a version older than 1.8.1.759 are affected. The product is maintained by an unknown vendor and operates on WordPress platforms. Users with contributor or similar low‑privilege roles can exploit the flaw; administrators and higher‑level users are not directly impacted unless they grant contributors the same editor access.

Risk and Exploitability

The EPSS score is not available, and the vulnerability is not listed in CISA’s Known Exploited Vulnerabilities catalog, suggesting limited public exploitation data. Nevertheless, the attack vector is inferred to be via the WordPress editor page, which an authenticated contributor can access. Once the API key is exposed, the attacker can use the REST API to publish posts, modify content, or perform other actions with elevated privileges. The severity of the impact – arbitrary content control – indicates a high risk to the confidentiality, integrity, and availability of the site.

Generated by OpenCVE AI on November 6, 2026 at 07:25 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Surfer plugin to version 1.8.1.759 or later, which removes the key disclosure and strengthens role checks for the REST API.
  • If an upgrade cannot be performed immediately, modify the plugin or WordPress theme to hide the API key from the editor page for contributor‑level users and revoke that capability from the role.
  • Configure the REST API to require proper authorization checks and limit access to high‑privilege roles, or block the plugin’s privileged endpoints using web‑application firewall rules.

Generated by OpenCVE AI on November 6, 2026 at 07:25 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 07:45:00 +0000

Type Values Removed Values Added
Weaknesses CWE-200
CWE-285

Fri, 06 Nov 2026 06:15:00 +0000

Type Values Removed Values Added
Description The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.
Title Surfer < 1.8.1.759 - Contributor+ Privilege Escalation via Editor API Key Disclosure
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-11-06T06:00:26.032Z

Reserved: 2026-10-28T17:18:28.308Z

Link: CVE-2026-118639

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-11-06T06:16:41.250

Modified: 2026-11-06T06:16:41.250

Link: CVE-2026-118639

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T07:30:09Z

Weaknesses
  • CWE-200

    Exposure of Sensitive Information to an Unauthorized Actor

  • CWE-285

    Improper Authorization