Description
The aBlocks – Gutenberg Blocks, User Dashboard Builder, Popup Builder, Form Builder & Animation Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.18.0 via the 'id' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract the full rendered body content of any password-protected post of any post type by embedding the shortcode with the target post's ID. Author-level attackers and above can additionally publish a post embedding the shortcode, exposing the password-protected content to unauthenticated visitors.
Published: 2026-11-07
Score: 4.3 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Sensitive Information Exposure
Action: Update Plugin
AI Analysis

Impact

The aBlocks plugin for WordPress contains a flaw in the ablocks_template shortcode that allows an authenticated user with contributor level or higher to supply an arbitrary post ID via the 'id' parameter. When the shortcode is rendered the plugin returns the complete rendered body content of the requested post even if that post is password‑protected, thereby leaking sensitive information. An author or higher can take this further by publishing a post that embeds the shortcode, making the protected content visible to all visitors.

Affected Systems

Any WordPress site running aBlocks version 2.18.0 or earlier is affected. Users who can create or edit content at contributor level or above can trigger the information exposure. The vulnerability exists regardless of the particular post type.

Risk and Exploitability

The CVSS score of 4.3 indicates a low to moderate severity, and the EPSS score is not available, so the likelihood of exploitation is currently unknown. The vulnerability is not listed in the CISA KEV catalog. Exploitation requires only a contributor‑level authenticated session, so the attack vector is internal; an attacker must already have access to the site’s content management role. Because the exposed data is the full body of password‑protected content, sensitive post details—including private text, embedded media, or proprietary information—could be harvested. The impact is primarily confidentiality breach and potential reputational harm if the leaked content is publicly visible.

Generated by OpenCVE AI on November 7, 2026 at 08:16 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the aBlocks plugin to the latest version that removes the shortcode flaw.
  • If an upgrade is not possible, remove or disable the ablocks_template shortcode from all posts and pages.
  • Restrict contributor permissions so that authenticated users cannot read password‑protected posts or embed shortcodes that reference post IDs.

Generated by OpenCVE AI on November 7, 2026 at 08:16 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 06:45:00 +0000

Type Values Removed Values Added
Description The aBlocks – Gutenberg Blocks, User Dashboard Builder, Popup Builder, Form Builder & Animation Builder plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.18.0 via the 'id' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract the full rendered body content of any password-protected post of any post type by embedding the shortcode with the target post's ID. Author-level attackers and above can additionally publish a post embedding the shortcode, exposing the password-protected content to unauthenticated visitors.
Title aBlocks <= 2.18.0 - Authenticated (Contributor+) Sensitive Information Exposure in 'ablocks_template' Shortcode
Weaknesses CWE-200
References
Metrics cvssV3_1

{'score': 4.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T06:39:41.306Z

Reserved: 2026-10-28T20:29:12.528Z

Link: CVE-2026-118801

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T07:17:03.397

Modified: 2026-11-07T07:17:03.513

Link: CVE-2026-118801

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T08:30:15Z

Weaknesses
  • CWE-200

    Exposure of Sensitive Information to an Unauthorized Actor