Description
The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter in all versions up to, and including, 1.4.43 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce is localized to any published page carrying the calendar shortcode, making the adddetails endpoint reachable by any authenticated user with Subscriber-level access or above.
Published: 2026-10-30
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch Now
AI Analysis

Impact

The CP Multi View Events Calendar plugin for WordPress contains a stored cross‑site scripting flaw in the 'Subject' parameter. Insufficient input sanitization and output escaping enable attackers who are authenticated with Subscriber‑level or higher privileges to insert arbitrary JavaScript. When any user views a page containing the injected event, the malicious scripts execute, allowing session hijacking, cookie theft, or defacement. This is a classic XSS vulnerability identified as CWE‑79.

Affected Systems

The flaw affects installations of the Codepeople CP Multi View Events Calendar plugin version 1.4.43 and all earlier releases. WordPress sites that have this plugin activated and allow users with Subscriber or higher rights to create or edit events can trigger the vulnerability. The injected payload is stored in the plugin’s JavaScript calendar code and the datafeed endpoint that accepts the 'Subject' value, meaning every site running an affected version is exposed.

Risk and Exploitability

The CVSS score of 6.4 indicates a moderate severity that still represents significant risk to user session confidentiality and integrity. No EPSS data is available, and the issue is not listed in the CISA KEV catalogue, implying that widespread exploitation has not been observed. Attackers must be authenticated with at least Subscriber privileges, but they can reach the vulnerable endpoint from any published page that includes the calendar shortcode, so any typical WordPress site with an affected plugin and subscriber users is a potential target.

Generated by OpenCVE AI on October 30, 2026 at 18:40 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade CP Multi View Events Calendar to a version newer than 1.4.43 whenever it becomes available.
  • If an upgrade is not possible, remove or disable the plugin to eliminate the storage vector for malicious scripts.
  • Restrict or revoke Subscriber‑level access to the event creation function and, if necessary, apply custom input validation or output escaping to the 'Subject' field until a stable patch is released.

Generated by OpenCVE AI on October 30, 2026 at 18:40 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 19:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Description The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter in all versions up to, and including, 1.4.43 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce is localized to any published page carrying the calendar shortcode, making the adddetails endpoint reachable by any authenticated user with Subscriber-level access or above.
Title CP Multi View Events Calendar <= 1.4.43 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'Subject' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-30T18:08:59.759Z

Reserved: 2026-10-29T15:20:55.999Z

Link: CVE-2026-119176

cve-icon Vulnrichment

Updated: 2026-10-30T18:01:59.803Z

cve-icon NVD

Status : Deferred

Published: 2026-10-30T18:17:25.437

Modified: 2026-10-30T19:18:20.327

Link: CVE-2026-119176

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T18:45:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')