Description
The AAA Autoload Optimizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'option_page' parameter in all versions up to, and including, 1.7.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the plugin's Option Tracking setting to be configured to 'Legacy' mode, and succeeds despite WordPress ultimately returning HTTP 403 to the low-privileged caller because the vulnerable 'all' filter fires before the capability check in wp-admin/options.php.
Published: 2026-11-06
Score: 4.9 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch plugin
AI Analysis

Impact

The AAA Autoload Optimizer plugin contains a stored XSS flaw that can be triggered by an authenticated user, from subscriber level and higher, who passes an arbitrary value in the option_page parameter. The flaw is exercised through the WordPress "all" filter hooked to the plugin, allowing the attacker to store malicious JavaScript that runs whenever a user visits an affected page. The injection succeeds only when the plugin’s Option Tracking is set to Legacy mode, and it is executed before WordPress performs its normal capability check, so the attacker can bypass the HTTP 403 response that would otherwise be returned.

Affected Systems

WordPress sites that have the AAA Autoload Optimizer plugin installed with a version equal to or older than 1.7.0, regardless of additional plugins or themes. The plugin is provided by progressplanner and targets WordPress installations hosting the plugin.

Risk and Exploitability

The CVSS score of 4.9 places the vulnerability in a low to medium severity range, and the EPSS score is not available while the issue is not listed in CISA’s KEV catalog, indicating a current lower likelihood of widespread exploitation. However, because the flaw only requires subscriber‑level abuse and a specific plugin setting, any site that has granted that level of access to an attacker and left legacy mode enabled is potentially susceptible. An attacker who successfully injects code can deface pages or phish users, compromising the integrity and trustworthiness of the site.

Generated by OpenCVE AI on November 6, 2026 at 12:51 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the AAA Autoload Optimizer plugin to the latest version that resolves the XSS issue.
  • If an update is not available, remove the plugin entirely.
  • If removal is not an option, disable the Option Tracking Legacy mode in the plugin’s settings to prevent the vulnerable filter path from being executed.

Generated by OpenCVE AI on November 6, 2026 at 12:51 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The AAA Autoload Optimizer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'option_page' parameter in all versions up to, and including, 1.7.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the plugin's Option Tracking setting to be configured to 'Legacy' mode, and succeeds despite WordPress ultimately returning HTTP 403 to the low-privileged caller because the vulnerable 'all' filter fires before the capability check in wp-admin/options.php.
Title AAA Autoload Optimizer <= 1.7.0 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'option_page' Parameter via 'all' Hook
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 4.9, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T11:17:37.313Z

Reserved: 2026-10-29T16:13:23.645Z

Link: CVE-2026-119211

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:19.450

Modified: 2026-11-06T12:17:19.570

Link: CVE-2026-119211

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T13:00:07Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')