Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AdvancedCoding wpDiscuz wpdiscuz allows Stored XSS.This issue affects wpDiscuz: from n/a through 7.6.73.
Published: 2026-11-04
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Patch Immediately
AI Analysis

Impact

An improper neutralization of input leads to a stored cross‑site scripting vulnerability in the AdvancedCoding wpDiscuz WordPress plugin. The flaw allows an attacker to inject malicious scripts that are persisted in the database and served to any user who views the affected content. This can enable session hijacking, defacement, or theft of sensitive information via the victim’s browser. The weakness is a classic stored XSS, cataloged as CWE‑79.

Affected Systems

Affects the WordPress wpDiscuz plugin version 7.6.73 and earlier. Any WordPress site that has AdvancedCoding wpDiscuz installed in a version from the initial release through 7.6.73 is vulnerable.

Risk and Exploitability

The CVSS score of 7.1 indicates a high risk. EPSS is not available, and the vulnerability is not listed in the CISA KEV catalog. Based on the description, the attack vector is likely through user‑generated content such as comment submissions that are stored and rendered without proper escaping. Prompt patching is recommended because successful exploitation would give attackers arbitrary script execution in the context of the site visitor.

Generated by OpenCVE AI on November 4, 2026 at 10:08 UTC.

Remediation

Vendor Solution

Update the WordPress wpDiscuz plugin to the latest available version (at least 7.6.74).


OpenCVE Recommended Actions

  • Apply the latest wpDiscuz plugin update (v7.6.74 or later).
  • Until the update is applied, disable or restrict the comment posting form, or use a sanitization filter to strip script tags from comment content.
  • Implement a Content Security Policy that disallows inline scripts and restricts script sources to trusted domains.

Generated by OpenCVE AI on November 4, 2026 at 10:08 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 04 Nov 2026 08:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AdvancedCoding wpDiscuz wpdiscuz allows Stored XSS.This issue affects wpDiscuz: from n/a through 7.6.73.
Title WordPress wpDiscuz plugin <= 7.6.73 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-04T08:00:17.394Z

Reserved: 2026-10-30T00:29:39.565Z

Link: CVE-2026-119366

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-04T08:17:16.523

Modified: 2026-11-04T08:17:16.640

Link: CVE-2026-119366

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T10:15:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')