Description
phpMyAdmin through 5.2.3 contains a missing re-authentication vulnerability that allows authenticated attackers to remove two-factor authentication by posting the 2fa key to /config/set. Attackers holding a hijacked session can submit key=2fa with a null JSON value to SetConfigController, stripping 2FA so later logins require only the MySQL password.
Published: 2026-10-30
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Removal of two‑factor authentication leading to possible unauthorized database access
Action: Immediate Patch
AI Analysis

Impact

The vulnerability lies in phpMyAdmin’s earlier versions up to 5.2.3, where an authenticated user can bypass the two‑factor authentication requirement. By posting a specially crafted request to /config/set with the key parameter set to 2fa and a null JSON value, the attacker can remove the 2FA setting from the configuration. When 2FA is disabled, subsequent logins only require the MySQL password, thereby permitting an attacker who already holds a hijacked session to gain persistent access to the database backend. This flaw is categorized as CWE‑620.

Affected Systems

The flaw affects phpMyAdmin up to and including version 5.2.3. The product is available from the phpMyAdmin project, and any installation that has not upgraded past 5.2.3 is susceptible.

Risk and Exploitability

The CVSS base score of 5.3 indicates a medium‑severity vulnerability. Exploitation requires the attacker to already possess an authenticated session, which can occur commonly after session hijacking or credential compromise. Because the attack vector is local to a web session, the EPSS score is not provided. The flaw is not listed in the CISA KEV catalog, but the lack of re‑authentication may still yield significant risk if an attacker can hijack a session. Immediate remediation is advised before attackers obtain persistent access.

Generated by OpenCVE AI on October 30, 2026 at 12:45 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade phpMyAdmin to a version newer than 5.2.3, which includes the missing re‑authentication check.
  • If an upgrade cannot be performed immediately, configure the web server or a reverse proxy to block POST requests to /config/set that include the key=2fa parameter or any null JSON payload, thereby preventing the configuration change.
  • Strengthen session management by enforcing strict session timeouts, disabling session reuse, and requiring re‑authentication for configuration modifications to mitigate the risk of session hijacking.

Generated by OpenCVE AI on October 30, 2026 at 12:45 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 11:45:00 +0000

Type Values Removed Values Added
Description phpMyAdmin through 5.2.3 contains a missing re-authentication vulnerability that allows authenticated attackers to remove two-factor authentication by posting the 2fa key to /config/set. Attackers holding a hijacked session can submit key=2fa with a null JSON value to SetConfigController, stripping 2FA so later logins require only the MySQL password.
Title phpMyAdmin through 5.2.3 Two-Factor Authentication Removal via /config/set
First Time appeared Phpmyadmin
Phpmyadmin phpmyadmin
Weaknesses CWE-620
CPEs cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*
Vendors & Products Phpmyadmin
Phpmyadmin phpmyadmin
References
Metrics cvssV3_1

{'score': 4.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N'}

cvssV4_0

{'score': 5.3, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N'}


Subscriptions

Phpmyadmin Phpmyadmin
cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-30T11:30:57.953Z

Reserved: 2026-10-30T02:41:15.377Z

Link: CVE-2026-119429

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T12:16:40.187

Modified: 2026-10-30T12:16:40.187

Link: CVE-2026-119429

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T13:00:15Z

Weaknesses
  • CWE-620

    Unverified Password Change