Description
Cross-Site Request Forgery (CSRF) vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Cross Site Request Forgery.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.
Published: 2026-10-30
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Cross‑Site Request Forgery
Action: Patch Immediately
AI Analysis

Impact

The WPExperts APIExperts Square for WooCommerce plugin contains a Cross‑Site Request Forgery vulnerability that lets an attacker force an authenticated user to submit unintended requests against the WooCommerce store. This could enable unauthorized changes, such as modifying order details or altering site configuration, without the user’s knowledge.

Affected Systems

WordPress sites using the APIExperts Square for WooCommerce plugin from WPExperts, in any version up to and including 4.7.5. All subsequent releases, starting with 4.7.6, are not affected. Site administrators should confirm the installed plugin version and plan an upgrade if necessary.

Risk and Exploitability

The CVSS v3.1 score is 5.4, indicating a moderate severity. EPSS data is unavailable, and the vulnerability is not listed in the CISA KEV catalog, suggesting no documented mass exploitation. The attack vector is web‑based and requires the victim to be authenticated to the store’s administration area; an attacker can craft a link or form that submits a request to a protected endpoint executed in the victim’s browser.

Generated by OpenCVE AI on October 30, 2026 at 17:21 UTC.

Remediation

Vendor Solution

Update the WordPress APIExperts Square for WooCommerce plugin to the latest available version (at least 4.7.6).


OpenCVE Recommended Actions

  • Upgrade the APIExperts Square for WooCommerce plugin to version 4.7.6 or later, which removes the CSRF vulnerability.
  • Restrict access to the plugin’s administrative pages so that only users with the appropriate capabilities can reach them.
  • Monitor the site for anomalous administrative activity or unusual requests and establish alerts for suspicious actions.

Generated by OpenCVE AI on October 30, 2026 at 17:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 17:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Fri, 30 Oct 2026 16:30:00 +0000

Type Values Removed Values Added
Description Cross-Site Request Forgery (CSRF) vulnerability in WPExperts APIExperts Square for WooCommerce woosquare allows Cross Site Request Forgery.This issue affects APIExperts Square for WooCommerce: from n/a through 4.7.5.
Title WordPress APIExperts Square for WooCommerce plugin <= 4.7.5 - Cross Site Request Forgery (CSRF) vulnerability
Weaknesses CWE-352
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-10-30T16:39:18.607Z

Reserved: 2026-10-30T08:15:34.422Z

Link: CVE-2026-119466

cve-icon Vulnrichment

Updated: 2026-10-30T16:39:10.275Z

cve-icon NVD

Status : Deferred

Published: 2026-10-30T17:17:19.707

Modified: 2026-10-30T17:18:40.007

Link: CVE-2026-119466

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T17:30:13Z

Weaknesses
  • CWE-352

    Cross-Site Request Forgery (CSRF)