Description
Missing Authorization vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Media LIbrary Assistant: from n/a through 3.43.
Published: 2026-11-07
Score: 4.3 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized Access via Broken Access Control
Action: Apply Patch
AI Analysis

Impact

The Media Library Assistant plugin contains a missing authorization flaw that allows attackers to exploit incorrectly configured access control settings, enabling them to perform actions they would normally be prohibited from doing. This broken access control can lead to unauthorized viewing or modification of media assets stored in a WordPress site. The weakness is a classic example of inadequate authorization checks, matching CWE‑862. The description indicates that any user—depending on the site’s role configuration—could bypass restrictions, possibly leading to data exposure or integrity compromise.

Affected Systems

WordPress sites using the Media Library Assistant plugin up to version 3.43 are affected. All releases from any version before the fix through 3.43 are vulnerable, regardless of other installed plugins or WordPress core updates. Site administrators should identify any instance of the plugin within this version range.

Risk and Exploitability

The CVSS score of 4.3 suggests moderate base severity, but lack of an EPSS score means exploitation prevalence is unknown. The vulnerability is not listed in the CISA KEV catalog, indicating no known widespread exploitation. The likely attack vector is remote via the web interface, where an unauthenticated or minimally privileged user can send crafted requests to the plugin’s endpoint. Because the flaw relies on incorrect ACL configuration, the attacker may succeed only if role permissions are misassigned; however, standard misconfigurations are common in many installations.

Generated by OpenCVE AI on November 7, 2026 at 10:27 UTC.

Remediation

Vendor Solution

Update the WordPress Media LIbrary Assistant plugin to the latest available version (at least 3.44).


OpenCVE Recommended Actions

  • Apply the latest WordPress Media Library Assistant plugin update (v3.44 or newer).
  • Verify WordPress roles and capabilities are set correctly and confirm the plugin’s role settings enforce appropriate restrictions.
  • Disable or uninstall the Media Library Assistant plugin if it is not needed for site functionality.

Generated by OpenCVE AI on November 7, 2026 at 10:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 09:30:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Media LIbrary Assistant: from n/a through 3.43.
Title WordPress Media LIbrary Assistant plugin <= 3.43 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 4.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T09:13:16.009Z

Reserved: 2026-10-30T09:20:18.655Z

Link: CVE-2026-119491

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T10:17:08.193

Modified: 2026-11-07T10:17:08.320

Link: CVE-2026-119491

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T10:30:12Z

Weaknesses