Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Metaphor Creations, LLC Ditty ditty-news-ticker allows Stored XSS.This issue affects Ditty: from n/a through 3.1.71.
Published: 2026-11-07
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Apply patch
AI Analysis

Impact

Metaphor Creations, LLC’s Ditty news ticker plugin allows legacy users to store arbitrary JavaScript in the plugin’s configuration which is later rendered in web pages without proper escaping. The vulnerability is a classic stored XSS flaw (CWE‑79) that could be used by an attacker to execute code in any user’s browser that views the ticker, potentially hijacking sessions, defacing content, or delivering malware. The impact is limited to browsers that read the affected content and does not directly compromise the server side of the WordPress site.

Affected Systems

WordPress sites running the Ditty plugin by Metaphor Creations, version 3.1.71 and all earlier releases are vulnerable. Any site that has not upgraded past 3.1.71 may be at risk.

Risk and Exploitability

The CVSS score of 6.5 indicates a moderate severity, and although the EPSS score is currently unavailable, the lack of a KEV listing suggests no known exploits in the wild. The likely attack vector is through the plugin’s configuration interface where an authenticated user can insert malicious code that will be rendered for any visitor. Because the vulnerability is stored, a single compromised entry can affect all users who view the ticker. The risk is therefore moderate to high for sites that rely on this plugin and do not maintain a WAF or other content filtering.

Generated by OpenCVE AI on November 7, 2026 at 11:29 UTC.

Remediation

Vendor Solution

Update the WordPress Ditty plugin to the latest available version (at least 3.1.72).


OpenCVE Recommended Actions

  • Upgrade the Ditty plugin to version 3.1.72 or later to remove the stored XSS flaw.
  • If an immediate upgrade is not possible, disable the plugin or delete all ticker content that allows script injection until the patch can be applied.
  • Audit other WordPress plugins and the core installation for similar XSS weaknesses and keep all components updated; consider deploying a Web Application Firewall to filter out malicious script payloads.

Generated by OpenCVE AI on November 7, 2026 at 11:29 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 10:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Metaphor Creations, LLC Ditty ditty-news-ticker allows Stored XSS.This issue affects Ditty: from n/a through 3.1.71.
Title WordPress Ditty plugin <= 3.1.71 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T10:03:35.865Z

Reserved: 2026-10-30T09:20:18.655Z

Link: CVE-2026-119493

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T10:17:08.360

Modified: 2026-11-07T10:17:08.487

Link: CVE-2026-119493

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T11:30:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')