Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows Code Injection.This issue affects Media LIbrary Assistant: from n/a through 3.43.
Published: 2026-11-07
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Content Injection (XSS)
Action: Patch Now
AI Analysis

Impact

Improper neutralization of script‑related HTML tags in the Media Library Assistant plugin allows attackers to inject malicious code that can be executed in the context of the website. This basic XSS flaw can lead to session hijacking, defacement, or the execution of arbitrary client‑side scripts when users view affected pages. The impact is a loss of confidentiality and potential integrity compromise of user data, but it does not provide remote code execution on the server side.

Affected Systems

The vulnerability affects the WordPress Media Library Assistant plugin developed by David Lingren, affecting all releases up to and including version 3.43. No specific WordPress core or other plugins are mentioned as impacted.

Risk and Exploitability

The CVSS score of 5.3 indicates a moderate severity for this XSS flaw. The EPSS score is not available, and it is not listed in CISA KEV, suggesting no high‑profile exploitation has been reported yet. Based on the description, the likely attack vector is external: an attacker can craft a request that injects script tags into the plugin’s output viewed by site visitors. Although the description does not state authentication requirements, the injection could potentially affect any user who can submit data through the plugin’s interface.

Generated by OpenCVE AI on November 7, 2026 at 11:20 UTC.

Remediation

Vendor Solution

Update the WordPress Media LIbrary Assistant plugin to the latest available version (at least 3.44).


OpenCVE Recommended Actions

  • Update the Media Library Assistant plugin to version 3.44 or later.
  • If an upgrade is not possible immediately, disable the plugin or restrict access to its admin interface until a patch is applied.
  • Ensure that any custom code interacting with the plugin implements proper input sanitization and escaping to prevent script tags from being rendered.

Generated by OpenCVE AI on November 7, 2026 at 11:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 10:45:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in David Lingren Media LIbrary Assistant media-library-assistant allows Code Injection.This issue affects Media LIbrary Assistant: from n/a through 3.43.
Title WordPress Media LIbrary Assistant plugin <= 3.43 - Content Injection vulnerability
Weaknesses CWE-80
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T10:43:24.665Z

Reserved: 2026-10-30T09:20:18.655Z

Link: CVE-2026-119496

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T11:16:58.720

Modified: 2026-11-07T11:16:58.840

Link: CVE-2026-119496

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T11:30:13Z

Weaknesses
  • CWE-80

    Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)