Description
phpMyAdmin through 5.2.3 contains a stored cross-site scripting vulnerability that allows database users with CREATE privilege to inject script via unescaped table names in DesignerHistory.display(). Attackers can create a table whose name contains HTML markup that executes in another user's session when they add a condition on it in Designer query mode.
Published: 2026-10-30
Score: 5.1 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (client‑side script execution)
Action: Update Immediately
AI Analysis

Impact

phpMyAdmin through version 5.2.3 contains a stored cross‑site scripting flaw that allows any database user with CREATE privilege to inject arbitrary HTML and JavaScript into table names. When such a maliciously crafted table name is used in the Designer query history interface, the unescaped name is rendered in another user’s session, causing client‑side code to execute. The vulnerability does not provide direct code execution on the server but can compromise the victim’s browser context, enabling session hijacking, credential theft, or defacement.

Affected Systems

All installations of phpMyAdmin with version 5.2.3 or earlier are affected. The flaw is exploitable for users who have been granted the CREATE privilege on the target database, even if they are not administrators of the phpMyAdmin instance.

Risk and Exploitability

The CVSS score of 5.1 indicates a medium severity assessment. No EPSS score is publicly available, and the vulnerability is not listed in the CISA KEV catalog, suggesting a lower observed exploitation rate. However, the attack requires the attacker to have database‑level CREATE permissions, which are often granted to application users or shared accounts. If such privileges exist, the vulnerability can be leveraged to inject malicious scripts that run in other users’ browsers when they interact with the Designer feature. The risk is therefore contingent on privilege configuration and the usage patterns of the Designer tool within the environment.

Generated by OpenCVE AI on October 30, 2026 at 12:38 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade phpMyAdmin to a patched version that eliminates the XSS issue (e.g., version 5.2.4 or newer).
  • Enforce the principle of least privilege by restricting or revoking CREATE permission for non‑trusted database users.
  • If an immediate upgrade is not feasible, apply a temporary code modification to properly escape or filter table names in DesignerHistory.display() before rendering them to the user.

Generated by OpenCVE AI on October 30, 2026 at 12:38 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 11:45:00 +0000

Type Values Removed Values Added
Description phpMyAdmin through 5.2.3 contains a stored cross-site scripting vulnerability that allows database users with CREATE privilege to inject script via unescaped table names in DesignerHistory.display(). Attackers can create a table whose name contains HTML markup that executes in another user's session when they add a condition on it in Designer query mode.
Title phpMyAdmin through 5.2.3 Stored XSS via Designer Query History Table Name
First Time appeared Phpmyadmin
Phpmyadmin phpmyadmin
Weaknesses CWE-79
CPEs cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*
Vendors & Products Phpmyadmin
Phpmyadmin phpmyadmin
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N'}

cvssV4_0

{'score': 5.1, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N'}


Subscriptions

Phpmyadmin Phpmyadmin
cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-30T11:31:11.051Z

Reserved: 2026-10-30T10:53:30.822Z

Link: CVE-2026-119563

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T12:16:43.830

Modified: 2026-10-30T12:16:43.830

Link: CVE-2026-119563

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T13:15:15Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')