Description
Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read vulnerability in blo_bhead_id_* accessors in readfile.cc that read ID fields without block length checks. Attackers can supply a crafted .blend file with short ID blocks that, when browsed or appended from, causes heap over-reads leading to crashes or heap memory disclosure.
Published: 2026-10-30
Score: 6.9 Medium
EPSS: n/a
KEV: No
Impact: Out-of-bounds read leading to memory disclosure or crash
Action: Patch Update
AI Analysis

Impact

Blender versions before 4.5.15 and before 5.2.3 contain an out-of-bounds read flaw in the blo_bhead_id_* accessors in readfile.cc. The implementation reads ID fields of block headers without ensuring the block payload length is sufficient. An attacker can supply a crafted .blend file with short ID blocks that, when processed by the program—such as during file browsing, opening or appending—triggers a heap over-read. The read may result in a crash or the disclosure of heap memory contents, potentially leaking internal data.

Affected Systems

The affected product is Blender, released by the Blender Foundation. All releases prior to 4.5.15 and all 5.x releases before 5.2.3 are vulnerable regardless of operating system, including Windows, macOS, and Linux. No specific sub-components are listed beyond the mentioned readfile.cc functions.

Risk and Exploitability

The CVSS score of 6.9 indicates moderate severity. The EPSS score is not available, and the issue is not listed in CISA’s KEV catalog. Based on the description, the likely attack vector is a crafted .blend file that is opened or otherwise processed by Blender. While the flaw does not provide a straightforward remote code execution path, it can lead to denial of service or memory disclosure, affecting confidentiality, integrity, or availability of any user or system that processes the malicious file.

Generated by OpenCVE AI on October 30, 2026 at 17:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade Blender to version 4.5.15 or later, or to 5.2.3 or later, to remove the flaw.
  • Avoid opening or importing .blend files from untrusted or unknown sources, as the vulnerability requires a malicious file to be processed.
  • If an upgrade is not immediately possible, restrict Blender’s access to directories or network shares where malicious files might reside, or validate file lengths and enforce bounds checks in any custom Blender file‑parsing routines.

Generated by OpenCVE AI on October 30, 2026 at 17:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 30 Oct 2026 15:30:00 +0000

Type Values Removed Values Added
Description Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read vulnerability in blo_bhead_id_* accessors in readfile.cc that read ID fields without block length checks. Attackers can supply a crafted .blend file with short ID blocks that, when browsed or appended from, causes heap over-reads leading to crashes or heap memory disclosure.
Title Blender before 4.5.15 and 5.x before 5.2.3 Out-of-Bounds Read via blo_bhead_id Accessors
First Time appeared Blender
Blender blender
Weaknesses CWE-125
CPEs cpe:2.3:a:blender:blender:*:*:*:*:*:*:*:*
Vendors & Products Blender
Blender blender
References
Metrics cvssV3_1

{'score': 6.1, 'vector': 'CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:H'}

cvssV4_0

{'score': 6.9, 'vector': 'CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-10-30T15:16:17.738Z

Reserved: 2026-10-30T14:49:29.119Z

Link: CVE-2026-119721

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Received

Published: 2026-10-30T16:17:55.767

Modified: 2026-10-30T16:17:55.767

Link: CVE-2026-119721

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-30T17:15:14Z

Weaknesses