Description
The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.
Published: 2026-11-04
Score: 7.1 High
EPSS: n/a
KEV: No
Impact: Unauthorized Access to Invoicing Data and Manipulation
Action: Immediate Patch
AI Analysis

Impact

The GetPaid plugin for WordPress contains an incorrect authorization flaw: the REST API controller maps all operations to generic WordPress post capabilities instead of the required manage_invoicing permission. An authenticated user with a lower role such as Editor or Author can therefore list other users' invoices, mark pending invoices as paid without recording a transaction, or create new invoices and published items. This flaw allows an attacker to view private financial data, tamper with invoice status, and generate fraudulent invoices, potentially compromising confidentiality, integrity, and financial correctness of the site.

Affected Systems

AyeCode Ltd's GetPaid plugin, a WordPress payment forms and invoicing solution, is affected. All installations using a version earlier than 2.8.63 are vulnerable. Users running WordPress with the GetPaid plugin installed under these older versions are at risk.

Risk and Exploitability

The CVSS score of 7.1 indicates a moderate to high severity. EPSS is not available, so the current probability of exploitation is unclear; however, because the flaw involves authenticated REST API access that is typically exposed to legitimate users, it is likely to be exploitable internally. The vulnerability is not listed in the CISA KEV catalog. An attacker would need to be an authenticated user with a role such as Editor or Author. Since the REST endpoints are accessible over HTTPS, the attack can be performed from within the site’s authenticated sessions, making it relatively easy for a disgruntled employee or compromised account to exploit. The lack of an official workaround forces administrators to address the issue by applying the vendor‑supplied patch.

Generated by OpenCVE AI on November 4, 2026 at 18:37 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the GetPaid plugin to version 2.8.63 or later, which implements the correct authorization checks for REST API operations.
  • Restrict REST API access to only users with the manage_invoicing capability by reviewing role assignments in WordPress and removing invoice‑related permissions from lower‑privileged roles, or by configuring the plugin’s settings to enforce stricter capability checks.
  • Audit REST API logs for abnormal invoice activity, review invoice records for unauthorized changes, and revoke any suspicious user accounts as appropriate.

Generated by OpenCVE AI on November 4, 2026 at 18:37 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 05 Nov 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 04 Nov 2026 17:00:00 +0000

Type Values Removed Values Added
Description The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.
Title GetPaid WordPress Plugin < 2.8.63 Incorrect Authorization via REST API
Weaknesses CWE-863
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N'}

cvssV4_0

{'score': 7.1, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-11-04T20:24:14.905Z

Reserved: 2026-10-30T15:31:52.079Z

Link: CVE-2026-119747

cve-icon Vulnrichment

Updated: 2026-11-04T20:24:07.307Z

cve-icon NVD

Status : Received

Published: 2026-11-04T17:17:34.607

Modified: 2026-11-04T21:17:55.970

Link: CVE-2026-119747

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T18:45:07Z

Weaknesses