Description
The GetPaid plugin for WordPress before 2.8.63 contains an authorization bypass vulnerability that allows unauthenticated attackers to access and manipulate another user's invoice by supplying its ID through the maybe_use_invoice parameter in process_invoice(), bypassing the ownership and key checks performed by is_authorized_to_pay(). Attackers can submit a known pending invoice ID via maybe_use_invoice to read checkout pricing details and initiate a checkout workflow, resulting in an unauthorized state change of the invoice to on-hold.
Published: 2026-11-04
Score: 6.9 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized invoice access and manipulation
Action: Patch Immediately
AI Analysis

Impact

The GetPaid WordPress plugin allows an unauthenticated user to specify a pending invoice ID through the maybe_use_invoice parameter in the process_invoice() function. The plugin’s is_authorized_to_pay() check is bypassed, which lets the attacker read checkout pricing details and transition the invoice from pending to on-hold, effectively changing the invoice state without consent. This constitutes an authorization bypass that can enable data leakage and unauthorized transaction manipulation.

Affected Systems

Any WordPress site running the GetPaid plugin prior to version 2.8.63 is vulnerable. AyeCode Ltd’s GetPaid payment, invoicing, and checkout solution is affected; the issue is limited to plugin versions below 2.8.63.

Risk and Exploitability

The CVSS score of 6.9 indicates moderate severity. The EPSS score is unknown, and the vulnerability is not currently listed in the CISA KEV catalog, implying no widely known exploits yet. The likely attack vector is a remote request to a publicly accessible endpoint where the attacker can supply a invoice ID via the maybe_use_invoice parameter. Because invoice identifiers are often predictable or discoverable, the exploitation risk is realistic but requires some knowledge of existing pending invoices.

Generated by OpenCVE AI on November 4, 2026 at 18:37 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update GetPaid to version 2.8.63 or newer.
  • Remove or restrict the maybe_use_invoice functionality so that only authenticated users can access it.
  • Review and tighten the plugin’s invoice permission checks to ensure that each invoice is accessed solely by its owner.

Generated by OpenCVE AI on November 4, 2026 at 18:37 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Thu, 05 Nov 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'yes', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Wed, 04 Nov 2026 17:00:00 +0000

Type Values Removed Values Added
Description The GetPaid plugin for WordPress before 2.8.63 contains an authorization bypass vulnerability that allows unauthenticated attackers to access and manipulate another user's invoice by supplying its ID through the maybe_use_invoice parameter in process_invoice(), bypassing the ownership and key checks performed by is_authorized_to_pay(). Attackers can submit a known pending invoice ID via maybe_use_invoice to read checkout pricing details and initiate a checkout workflow, resulting in an unauthorized state change of the invoice to on-hold.
Title GetPaid WordPress Plugin < 2.8.63 Authorization Bypass via maybe_use_invoice
Weaknesses CWE-639
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N'}

cvssV4_0

{'score': 6.9, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: VulnCheck

Published:

Updated: 2026-11-04T20:25:07.989Z

Reserved: 2026-10-30T15:31:52.079Z

Link: CVE-2026-119748

cve-icon Vulnrichment

Updated: 2026-11-04T20:24:57.322Z

cve-icon NVD

Status : Received

Published: 2026-11-04T17:17:34.770

Modified: 2026-11-04T21:17:56.110

Link: CVE-2026-119748

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-04T18:45:07Z

Weaknesses
  • CWE-639

    Authorization Bypass Through User-Controlled Key