Impact
The vulnerability is an improper access control flaw that allows an attacker who can authenticate to the database to gain higher privileges than intended. This flaw is classified as a privilege escalation weakness, meaning that an attacker can potentially execute actions or commands that should be restricted to authorized users. The consequence is loss of integrity and confidentiality on the affected database instance, allowing the attacker to read or modify data and potentially take control of the system.
Affected Systems
The flaw affects the Babelfish for PostgreSQL extension for AWS. All prior releases in the ranges 1.2–1.5, 2.1–2.15, 3.1–3.12, 4.0–4.8, and 5.1–5.4 are vulnerable. The vendor recommends upgrading to version 4.10 or later (including 5.6, 6.1, or newer). Any deployment using those older extension versions is at risk.
Risk and Exploitability
The CVSS v3 score of 8.7 classifies this as a high severity vulnerability. No EPSS score is available, so the current data does not indicate how often it is being exploited. The vulnerability is listed as not in the CISA KEV catalog. Attackers require valid user credentials to exploit the flaw, but once authenticated, the improper privilege management allows them to obtain elevated rights. Because the flaw involves improper access control, an exploit is likely feasible if an attacker gains a low‑privilege legitimate user account.
OpenCVE Enrichment