Description
The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'item_title (parsed from feed <item><title>)' parameter in all versions up to, and including, 5.2.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires an administrator to have previously configured a Feed-to-Post import pointing at an attacker-controlled feed URL, after which the attacker can rotate payloads at will without any further interaction with the site.
Published: 2026-11-06
Score: 5.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The vulnerability resides in the Feedzy RSS Aggregator plugin for WordPress versions up to 5.2.13, allowing unauthenticated attackers to store malicious JavaScript in a feed item title. Because the plugin parses the <item><title> element without proper sanitization, the injected code is rendered when any site visitor views a page that includes the imported feed. Thus any user who accesses the affected page or post can be exposed to remote script execution, potentially leading to session hijacking, defacement, or further compromise.

Affected Systems

The issue impacts WordPress installations that have the RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin installed, with a version of 5.2.13 or earlier. Any site where an administrator has created a Feed‑to‑Post import that points to an external feed—particularly one controlled by an attacker—can be compromised. Versions 5.2.14 and later contain the fix, so they are not affected.

Risk and Exploitability

The CVSS score of 5.4 places the vulnerability in the medium severity range. An attacker does not need credentials to inject the payload; however, the initial configuration requires an administrator to set a feed source that the attacker can control. Once set, the attacker can repeatedly emit different scripts without additional interaction. Because the exploit is a stored XSS, anyone who views the affected content will run the code, giving the attacker the same abilities as a standard XSS attack, such as stealing cookies or defacing the site. The EPSS score is not available, and the vulnerability is not in the CISA KEV catalog, implying no known widespread exploitation at present, but the attack path remains realistic for attackers with minimal effort once the feed import is in place.

Generated by OpenCVE AI on November 6, 2026 at 12:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the RSS Aggregator by Feedzy plugin to version 5.2.14 or later, where the item title sanitization has been fixed.
  • Remove or replace any Feed‑to‑Post imports that point to unknown or untrusted URLs, and restrict future imports to sources that are verified to be safe.
  • Implement a Content‑Security Policy that disallows inline scripts from untrusted sources, adding an extra layer of protection against accidental or residual XSS payloads.

Generated by OpenCVE AI on November 6, 2026 at 12:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'item_title (parsed from feed <item><title>)' parameter in all versions up to, and including, 5.2.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires an administrator to have previously configured a Feed-to-Post import pointing at an attacker-controlled feed URL, after which the attacker can rotate payloads at will without any further interaction with the site.
Title RSS Aggregator by Feedzy <= 5.2.13 - Unauthenticated Stored Cross-Site Scripting via Feed Item Title
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T11:17:40.619Z

Reserved: 2026-10-30T18:14:33.641Z

Link: CVE-2026-120035

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T12:17:20.067

Modified: 2026-11-06T12:17:20.200

Link: CVE-2026-120035

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T12:30:04Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')