Description
The Subscribe2 – Form, Email Subscribers & Newsletters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data[ip]’ parameter in all versions up to, and including, 10.47 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Published: 2026-11-07
Score: 7.2 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Immediate Patch
AI Analysis

Impact

The WordPress plugin Subscribe2 – Form, Email Subscribers & Newsletters contains an unauthenticated stored cross‑site scripting flaw. The flaw resides in the ‘data[ip]’ parameter, which is not properly sanitized or escaped. The result is that an attacker can embed arbitrary JavaScript into the plugin’s storage, which will run whenever any user loads a page that reflects that data. This weakness grants the ability to corrupt the user’s browser session, steal cookies, or deface content, and is classified as CWE‑79.

Affected Systems

The vulnerability affects all releases of Subscribe2 – Form, Email Subscribers & Newsletters up to and including version 10.47, distributed by wedevs for WordPress. Any WordPress site using a version in this range is potentially exposed.

Risk and Exploitability

With a CVSS score of 7.2 the flaw presents a moderate to high risk. No EPSS score is published, and the vulnerability is not listed in CISA’s KEV catalogue, suggesting it has not yet been widely exploited in the wild. Attackers can achieve the exploit without authentication, and the stored payload will persist until the plugin data is cleaned or the plugin is upgraded. The simplest exploitation path is to submit the malicious script via the exposed parameter and then lure or wait for site visitors to load the affected content.

Generated by OpenCVE AI on November 7, 2026 at 22:20 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Subscribe2 plugin to version 10.48 or later where the flaw is fixed.
  • If an upgrade cannot be performed immediately, eliminate the data[ip] input path or replace it with a validated, whitelisted input that escapes output.
  • Deploy a web application firewall rule that blocks or sanitizes script tags in data submitted to the Subscribe2 plugin.

Generated by OpenCVE AI on November 7, 2026 at 22:20 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 21:30:00 +0000

Type Values Removed Values Added
Description The Subscribe2 – Form, Email Subscribers & Newsletters plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data[ip]’ parameter in all versions up to, and including, 10.47 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Title Subscribe2 – Form, Email Subscribers & Newsletters <= 10.47 - Unauthenticated Stored Cross-Site Scripting via 'data[ip]' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T21:24:08.525Z

Reserved: 2026-11-02T16:19:23.937Z

Link: CVE-2026-120531

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T22:16:36.090

Modified: 2026-11-07T22:16:36.217

Link: CVE-2026-120531

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T22:30:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')