Description
The Advanced Custom Fields: Extended PRO plugin for WordPress is vulnerable to Limited Code Injection in all versions up to, and including, 0.9.2.6 via the render_field function. This is due to insufficient validation of form configuration parameters before merging into field settings and passing to call_user_func_array in the render_field method. This makes it possible for unauthenticated attackers to call arbitrary WordPress functions with controlled arguments. Method 1 requires the administrator to enable the non-default 'shortcode_preview' setting for the target form, while Method 2 requires the server environment to lack OpenSSL functions, causing ACF Pro's acf_decrypt to fall back to unverified base64 decoding.
Published: 2026-11-03
Score: 9.8 Critical
EPSS: n/a
KEV: No
Impact: Unauthenticated Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

The Advanced Custom Fields: Extended PRO plugin for WordPress has a limited code injection flaw in the render_field function. Insufficient validation of form configuration parameters allows unauthenticated attackers to inject arbitrary arguments into a call to call_user_func_array, enabling arbitrary WordPress functions to be executed with controlled arguments. This weakness, reflected in CWE‑434, can be leveraged for remote code execution.

Affected Systems

WordPress sites running ACF Extended: Advanced Custom Fields: Extended PRO versions up to and including 0.9.2.6 are affected. Any earlier releases share the same flaw, as the vulnerability exists across all versions prior to the fix. Sites using these plugins must verify the installed version and identify affected form configurations.

Risk and Exploitability

The CVSS score of 9.8 classifies this as a critical vulnerability. The EPSS score is not available, so the precise exploitation probability cannot be quantified, and the vulnerability is not currently listed in CISA’s KEV catalog. Attackers can exploit the flaw through two methods: either by enabling the non‑default ‘shortcode_preview’ setting for a target form or by leveraging server environments lacking OpenSSL functions, which forces the plugin to fall back to unverified base64 decoding during field decryption. In either scenario, an unauthenticated attacker can invoke any WordPress function, potentially leading to full compromise of the site.

Generated by OpenCVE AI on November 3, 2026 at 06:22 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update ACF Extended: Advanced Custom Fields: Extended PRO to the latest version (0.9.2.7 or newer) where the render_field validation is fixed.
  • If an immediate update is not possible, disable the non‑default ‘shortcode_preview’ setting on all forms to prevent the first exploitation method.
  • On servers that lack OpenSSL functions, install the OpenSSL library or update the PHP environment so that the plugin’s decryption fallback is no longer triggered; alternatively, remove the plugin if it is not required for site functionality.

Generated by OpenCVE AI on November 3, 2026 at 06:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 03 Nov 2026 05:00:00 +0000

Type Values Removed Values Added
Description The Advanced Custom Fields: Extended PRO plugin for WordPress is vulnerable to Limited Code Injection in all versions up to, and including, 0.9.2.6 via the render_field function. This is due to insufficient validation of form configuration parameters before merging into field settings and passing to call_user_func_array in the render_field method. This makes it possible for unauthenticated attackers to call arbitrary WordPress functions with controlled arguments. Method 1 requires the administrator to enable the non-default 'shortcode_preview' setting for the target form, while Method 2 requires the server environment to lack OpenSSL functions, causing ACF Pro's acf_decrypt to fall back to unverified base64 decoding.
Title Advanced Custom Fields: Extended PRO <= 0.9.2.6 - Unauthenticated Remote Code Execution via Dynamic Render Field Type
Weaknesses CWE-434
References
Metrics cvssV3_1

{'score': 9.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-03T04:43:09.501Z

Reserved: 2026-11-02T16:20:08.541Z

Link: CVE-2026-120534

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-03T05:18:31.987

Modified: 2026-11-03T05:18:32.140

Link: CVE-2026-120534

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-03T06:30:09Z

Weaknesses
  • CWE-434

    Unrestricted Upload of File with Dangerous Type