Description
The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This is due to insufficient input validation on the currency exchange rate parameter in the save_currency() AJAX handler, which lacks capability checks and allows subscriber-level users to store malicious SQL payloads that are later concatenated directly into ORDER BY clauses without proper sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries to extract sensitive information from the database.
Published: 2026-11-03
Score: 4.9 Medium
EPSS: n/a
KEV: No
Impact: Authenticated SQL Injection via exchange rate parameter
Action: Update Plugin
AI Analysis

Impact

This vulnerability allows an authenticated user with Shop Manager or higher role to inject arbitrary SQL through the exchange rate field in the WPML Multilingual & Multicurrency for WooCommerce plugin. The plugin concatenates the input directly into an ORDER BY clause without sanitization, enabling attackers to extract or modify database data. The weakness is a classic SQL injection (CWE‑89) and can lead to unauthorized data disclosure or manipulation.

Affected Systems

WordPress sites running the WPML Multilingual & Multicurrency for WooCommerce plugin version 5.5.7 and earlier are affected. Any installation of this plugin that has not been upgraded beyond 5.5.7 is susceptible, regardless of the WordPress core version.

Risk and Exploitability

The CVSS score of 4.9 indicates moderate severity. EPSS data is unavailable, so the likelihood of exploitation is unclear, but the vulnerability requires only an account with Shop Manager access and above, which are common on e‑commerce sites. The issue is not listed in the CISA KEV catalog, yet an attacker can append SQL statements during the AJAX currency update action to retrieve sensitive information from the database. The attack surface is limited to authenticated users with sufficient privileges, but that role is often granted to many staff members on busy online stores.

Generated by OpenCVE AI on November 3, 2026 at 06:23 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the plugin to the latest available release that fixes the SQL injection flaw.
  • If an upgrade is not immediately feasible, restrict the Shop Manager and higher roles from using the currency exchange rate editing feature by removing or tightening the capability that grants access to the save_currency AJAX action.
  • As a temporary patch, modify the save_currency handler to sanitize the exchange rate input and replace string concatenation with proper parameterized queries or safe handling of ORDER BY clauses.

Generated by OpenCVE AI on November 3, 2026 at 06:23 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 03 Nov 2026 05:00:00 +0000

Type Values Removed Values Added
Description The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This is due to insufficient input validation on the currency exchange rate parameter in the save_currency() AJAX handler, which lacks capability checks and allows subscriber-level users to store malicious SQL payloads that are later concatenated directly into ORDER BY clauses without proper sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries to extract sensitive information from the database.
Title WPML Multilingual & Multicurrency for WooCommerce <= 5.5.7 - Authenticated (Shop Manager+) SQL Injection via Exchange Rate Field
Weaknesses CWE-89
References
Metrics cvssV3_1

{'score': 4.9, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-03T04:43:09.150Z

Reserved: 2026-11-02T16:35:21.885Z

Link: CVE-2026-120563

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-03T05:18:33.647

Modified: 2026-11-03T05:18:33.790

Link: CVE-2026-120563

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-03T06:30:09Z

Weaknesses
  • CWE-89

    Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')