Description
The UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'badge' parameter in all versions up to, and including, 1.2.80 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is particularly effective against higher-privileged users — such as editors and administrators — who preview a Contributor's pending post containing the malicious shortcode.
Published: 2026-11-06
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting enabling arbitrary script execution in browsers
Action: Patch
AI Analysis

Impact

The vulnerability in UsersWP allows an authenticated attacker with contributor privileges or higher to embed malicious JavaScript into the "badge" shortcode parameter. Because the plugin does not sanitize or escape the badge input, the payload is stored and rendered whenever a page containing the shortcode is loaded, resulting in cross‑site scripting that can run arbitrary scripts in the context of the user viewing the page.

Affected Systems

UsersWP – Front‑end login form, User Registration, User Profile & Members Directory plugin for WordPress by stiofansisland. All releases up to and including version 1.2.80 are affected. Users who can add or edit content with contributor or higher roles can exploit the flaw.

Risk and Exploitability

With a CVSS score of 6.4 the severity is moderate, and the EPSS score is not available. The vulnerability is not in the CISA KEV catalog. An attacker must be authenticated and have contributor or higher access. The attack flow involves inserting a crafted badge shortcode into a post or page that a higher‑privileged editor or administrator proceeds to preview or view; the malicious script then executes in the browser of that privileged user each time the page is accessed.

Generated by OpenCVE AI on November 6, 2026 at 09:21 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update UsersWP to the latest version that contains the fix (>= 1.2.81).
  • If an immediate update is not possible, delete or disable the "badge" shortcode for users with contributor access to prevent future injections.
  • Restrict contributor permissions so that only trusted users can edit content containing shortcodes until the plugin patch is applied.

Generated by OpenCVE AI on November 6, 2026 at 09:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 08:45:00 +0000

Type Values Removed Values Added
Description The UsersWP – Front-end login form, User Registration, User Profile & Members Directory plugin for WP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'badge' parameter in all versions up to, and including, 1.2.80 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit is particularly effective against higher-privileged users — such as editors and administrators — who preview a Contributor's pending post containing the malicious shortcode.
Title UsersWP <= 1.2.80 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'badge' Shortcode Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-06T08:38:06.755Z

Reserved: 2026-11-02T18:57:14.944Z

Link: CVE-2026-120671

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T09:17:00.483

Modified: 2026-11-06T09:17:00.613

Link: CVE-2026-120671

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T09:30:08Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')