Description
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Magepeople inc. WpTravelly tour-booking-manager allows PHP Local File Inclusion.This issue affects WpTravelly: from n/a through 2.3.8.
Published: 2026-11-07
Score: 8.8 High
EPSS: n/a
KEV: No
Impact: Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

The WpTravelly plugin performs PHP include/require operations on filenames supplied by user input without proper validation or sanitization. This flaw creates an improper control of the filename used in the include statement, allowing an attacker to trigger a PHP Remote File Inclusion. The result may be that attacker‑controlled code is executed on the server or that sensitive local files are read, potentially giving the attacker access to confidential data or a foothold for further compromise.

Affected Systems

Magepeople inc. WpTravelly tour‑booking‑manager plugin, version 2.3.8 and earlier. The vulnerability is present in all releases that have not applied the patch; the fix is included starting with version 2.3.10.

Risk and Exploitability

The CVSS score of 8.8 reflects a high severity scenario in which remote exploitation is possible. The EPSS score is not available, and the issue is not listed in CISA KEV. Attackers can exploit this flaw by sending a crafted HTTP request that specifies an arbitrary filename to the plugin’s source code, triggering the PHP include chain. Because the vulnerability is reachable from the web interface, it can be leveraged by unauthenticated users or those with limited privileges.

Generated by OpenCVE AI on November 7, 2026 at 14:22 UTC.

Remediation

Vendor Solution

Update the WordPress WpTravelly plugin to the latest available version (at least 2.3.10).


OpenCVE Recommended Actions

  • Update the WordPress WpTravelly plugin to version 2.3.10 or later to apply the vendor patch.
  • If an update cannot be performed immediately, disable or uninstall the WpTravelly plugin to block further exploitation.
  • Ensure the WordPress installation has strict directory permissions and that functions such as include(), require() are not exposed to unauthenticated input; consider tightening PHP settings like disable_functions.
  • Implement web‑application firewall rules that detect and block suspicious inclusion patterns in incoming requests.

Generated by OpenCVE AI on November 7, 2026 at 14:22 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 13:00:00 +0000

Type Values Removed Values Added
Description Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Magepeople inc. WpTravelly tour-booking-manager allows PHP Local File Inclusion.This issue affects WpTravelly: from n/a through 2.3.8.
Title WordPress WpTravelly plugin <= 2.3.8 - Local File Inclusion vulnerability
Weaknesses CWE-98
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T12:44:22.589Z

Reserved: 2026-11-03T00:24:21.836Z

Link: CVE-2026-120839

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T13:16:34.973

Modified: 2026-11-07T13:16:35.097

Link: CVE-2026-120839

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T14:30:09Z

Weaknesses
  • CWE-98

    Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')