Description
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Magepeople inc. WpTravelly tour-booking-manager allows PHP Local File Inclusion.This issue affects WpTravelly: from n/a through 2.3.8.
Published: 2026-11-07
Score: 8.8 High
EPSS: n/a
KEV: No
Impact: Local File Inclusion leading to possible Remote Code Execution
Action: Immediate Patch
AI Analysis

Impact

A flaw in the WordPress WpTravelly tour‑booking‑manager plugin allows an attacker to supply a filename for use in a PHP include or require statement. Because the plugin does not sanitize the path, the attacker can cause the server to read arbitrary local files or execute malicious code stored on the system. This vulnerability can compromise the confidentiality of sensitive files, alter the integrity of the web application, and potentially provide full control over the server if the included payload is executed.

Affected Systems

The issue affects the Magepeople inc. WpTravelly tour‑booking‑manager plugin in all versions up to and including 2.3.8. WordPress sites that have installed or left any of these versions installed are exposed to the vulnerability.

Risk and Exploitability

The flaw carries a CVSS score of 8.8, indicating high severity. No EPSS score is available, but the lack of hardening in the current plugin version means attackers can exploit the vulnerability remotely through crafted HTTP requests that trigger the vulnerable include. It is not listed in the CISA KEV catalog; however, the high CVSS and the potential for remote code execution make it a critical risk that should be addressed promptly. The likely attack vector is via remote web requests that provide malicious parameters to the plugin's file inclusion logic.

Generated by OpenCVE AI on November 7, 2026 at 14:50 UTC.

Remediation

Vendor Solution

Update the WordPress WpTravelly plugin to the latest available version (at least 2.3.10).


OpenCVE Recommended Actions

  • Update the WpTravelly plugin to version 2.3.10 or later.
  • If an update cannot be applied immediately, configure the web server to deny traversal‑based access to the plugin's file include directories and reject requests containing directory traversal patterns (e.g., by using .htaccess or equivalent firewall rules).
  • Harden the WordPress installation by disabling file editing through the dashboard, setting the PHP source files to read‑only permissions (e.g., 440/640), and ensuring that the web server processes run with the least privileges necessary.

Generated by OpenCVE AI on November 7, 2026 at 14:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 13:00:00 +0000

Type Values Removed Values Added
Description Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Magepeople inc. WpTravelly tour-booking-manager allows PHP Local File Inclusion.This issue affects WpTravelly: from n/a through 2.3.8.
Title WordPress WpTravelly plugin <= 2.3.8 - Local File Inclusion vulnerability
Weaknesses CWE-98
References
Metrics cvssV3_1

{'score': 8.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T12:43:33.620Z

Reserved: 2026-11-03T00:24:21.836Z

Link: CVE-2026-120841

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T13:16:35.130

Modified: 2026-11-07T13:16:35.253

Link: CVE-2026-120841

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T15:00:17Z

Weaknesses
  • CWE-98

    Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')