Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPMU DEV Smush Image Compression and Optimization wp-smushit allows Stored XSS.This issue affects Smush Image Compression and Optimization: from n/a through 4.3.5.
Published: 2026-11-06
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Now
AI Analysis

Impact

The vulnerability is an improper neutralization of user input that allows stored cross‑site scripting in the WPMU DEV Smush Image Compression and Optimization WordPress plugin. An attacker that can influence content handled by the plugin can inject JavaScript that will be executed in the browsers of visitors to the affected site. The weakness is classified as CWE‑79, a classic input‑validation flaw that compromises the confidentiality and integrity of the web application by allowing arbitrary script execution.

Affected Systems

The issue affects the WPMU DEV Smush Image Compression and Optimization plugin, from the earliest versions through 4.3.5. Any WordPress site that has the Smush plugin installed at a version equal to or older than 4.3.5 is potentially affected.

Risk and Exploitability

The CVSS score of 6.5 indicates a medium severity risk. The EPSS score is not available, so the current probability of active exploitation cannot be quantified, and the vulnerability is not listed in the CISA KEV catalog. Based on the description, the attack vector is a stored XSS that can be triggered by injecting malicious input via the plugin’s admin pages or media upload interface. Once an attacker decodes the side‑channel, they can execute arbitrary JavaScript in the browsers of visitors to the affected site.

Generated by OpenCVE AI on November 6, 2026 at 23:21 UTC.

Remediation

Vendor Solution

Update the WordPress Smush Image Compression and Optimization plugin to the latest available version (at least 4.3.6).


OpenCVE Recommended Actions

  • Update the Smush plugin to version 4.3.6 or later. This is the vendor‑provided solution that resolves the stored XSS flaw.
  • If an immediate update is not possible, disable or uninstall the Smush plugin temporarily to eliminate the attack surface until a patched version can be applied.
  • Apply a site‑wide input sanitization rule or deploy a security plugin that blocks unsanitized JavaScript in posts, comments, or media metadata to mitigate the risk while a permanent fix is pending.

Generated by OpenCVE AI on November 6, 2026 at 23:21 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Fri, 06 Nov 2026 22:45:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPMU DEV Smush Image Compression and Optimization wp-smushit allows Stored XSS.This issue affects Smush Image Compression and Optimization: from n/a through 4.3.5.
Title WordPress Smush Image Compression and Optimization plugin <= 4.3.5 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-06T22:30:37.910Z

Reserved: 2026-11-03T00:24:21.837Z

Link: CVE-2026-120845

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-06T23:17:21.260

Modified: 2026-11-06T23:17:21.400

Link: CVE-2026-120845

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-06T23:30:09Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')