Description
Missing Authorization vulnerability in Uncanny Owl Uncanny Automator uncanny-automator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Uncanny Automator: from n/a through 7.7.1.
Published: 2026-11-03
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Unauthorized Access/Privilege Escalation
Action: Update
AI Analysis

Impact

The Uncanny Automator plugin for WordPress suffers from a missing authorization flaw caused by incorrectly configured access control levels. The vulnerability allows an attacker to bypass intended role checks and perform actions normally reserved for higher-privileged users. It is inferred from the description that these actions may include creating, editing, or deleting automation tasks or accessing restricted plugin settings, potentially enabling unauthorized data modification or service disruption.

Affected Systems

The vulnerability affects all installations of the WordPress Uncanny Automator plugin version 7.7.1 and earlier. Any WordPress site that has not upgraded past 7.7.1 is susceptible, regardless of the hosting environment or other plugins in use.

Risk and Exploitability

The CVSS base score is 5.3, indicating moderate severity. EPSS data is not available, so the likelihood of exploitation cannot be quantified. The vulnerability is not listed in CISA's KEV catalog. It is inferred that the attack vector is through the WordPress web interface, as the flaw resides in the plugin's access control. The attacker would likely need an authenticated session, possibly with a user role that can interact with the plugin, to trigger the incorrectly configured permission checks.

Generated by OpenCVE AI on November 3, 2026 at 19:06 UTC.

Remediation

Vendor Solution

Update the WordPress Uncanny Automator plugin to the latest available version (at least 8.0.0).


OpenCVE Recommended Actions

  • Upgrade the Uncanny Automator plugin to version 8.0.0 or later to apply the vendor-released fix.
  • Review the site’s user roles and capabilities to ensure that only authorized users can access and control the plugin’s automation features.
  • If the plugin is not required for site operation, disable or uninstall it to eliminate the exposed attack surface.

Generated by OpenCVE AI on November 3, 2026 at 19:06 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 03 Nov 2026 20:30:00 +0000

Type Values Removed Values Added
First Time appeared Uncannyowl
Uncannyowl uncanny Automator
Wordpress-extensions
Wordpress-extensions uncanny Automator
Vendors & Products Uncannyowl
Uncannyowl uncanny Automator
Wordpress-extensions
Wordpress-extensions uncanny Automator

Tue, 03 Nov 2026 17:00:00 +0000

Type Values Removed Values Added
Description Missing Authorization vulnerability in Uncanny Owl Uncanny Automator uncanny-automator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Uncanny Automator: from n/a through 7.7.1.
Title WordPress Uncanny Automator plugin <= 7.7.1 - Broken Access Control vulnerability
Weaknesses CWE-862
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N'}


Subscriptions

Uncannyowl Uncanny Automator
Wordpress-extensions Uncanny Automator
cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-03T16:45:20.758Z

Reserved: 2026-11-03T00:24:21.837Z

Link: CVE-2026-120846

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-03T17:18:07.580

Modified: 2026-11-03T17:18:07.700

Link: CVE-2026-120846

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-03T20:15:14Z

Weaknesses