Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Stored XSS.This issue affects Elementor Website Builder: from n/a through 4.3.5.
Published: 2026-11-07
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting (XSS)
Action: Apply Patch
AI Analysis

Impact

A stored XSS flaw exists when the Elementor Website Builder plugin for WordPress does not properly neutralize input that is included in generated web pages. A crafted payload can be stored in a post, widget or other content element and subsequently executed in the browsers of any visitor to the affected page, allowing an attacker to hijack sessions, deface the site or deliver phishing attacks. The weakness is characteristic of CWE‑79, where input validation or output escaping is insufficient.

Affected Systems

All WordPress sites that use the Elementor Website Builder plugin version 4.3.5 or earlier are affected. The vulnerability is limited to the plugin itself and does not extend beyond its custom widgets or content fields.

Risk and Exploitability

The CVSS score of 6.5 indicates a medium severity risk. Because the EPSS score is not available, the likelihood of exploitation is unknown but the flaw is a stored XSS, which is typically easier to exploit than reflected variants. The issue is not listed in the CISA KEV catalog, suggesting no known large‑scale exploitation, however an attacker could easily craft a malicious payload if active users are present.

Generated by OpenCVE AI on November 7, 2026 at 11:29 UTC.

Remediation

Vendor Solution

Update the WordPress Elementor Website Builder plugin to the latest available version (at least 4.3.6).


OpenCVE Recommended Actions

  • Upgrade the Elementor plugin to version 4.3.6 or later, which contains the vendor patch for the XSS flaw.
  • Remove or disable any unused Elementor widgets or custom code that accepts user input, thereby reducing the potential attack surface.
  • Ensure that all content created through Elementor is properly escaped before rendering, verifying that output sanitization is enabled in the site configuration.

Generated by OpenCVE AI on November 7, 2026 at 11:29 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 10:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Stored XSS.This issue affects Elementor Website Builder: from n/a through 4.3.5.
Title WordPress Elementor Website Builder plugin <= 4.3.5 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T10:08:25.775Z

Reserved: 2026-11-03T00:24:21.837Z

Link: CVE-2026-120850

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T10:17:10.577

Modified: 2026-11-07T10:17:10.700

Link: CVE-2026-120850

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T11:30:13Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')