Description
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl.



To remediate this issue, users should upgrade to 4.0.3 or later.
Published: 2026-11-03
Score: 4.8 Medium
EPSS: n/a
KEV: No
Impact: Cross‑Site Scripting (XSS) via stored data
Action: Patch
AI Analysis

Impact

A stored XSS flaw exists in AWS Amplify maplibre-gl-js-amplify through the popupRender function and the AmplifyGeofenceControl component. Data supplied by an authenticated user or external source – specifically the title, address, place_name fields of a GeoJSON feature or the geofenceId – is rendered without input validation, permitting the injection of arbitrary JavaScript or HTML. An attacker who can provide such data can then execute code in the context of any user viewing the map or geofence control, potentially leading to session hijacking, data theft, or defacement. The CVSS score of 4.8 indicates moderate severity, but the vulnerability can be exploited by remote authenticated users.

Affected Systems

AWS Amplify maplibre-gl-js-amplify versions before 4.0.3 are affected. The vulnerability is present in the maplibre-gl-js-amplify JavaScript library when used in web applications that expose the popupRender or AmplifyGeofenceControl components to untrusted GeoJSON sources. Any deployment incorporating this library without applying the 4.0.3 release or newer is at risk.

Risk and Exploitability

The CVSS score of 4.8 reflects a moderate risk profile; however, no exploit is currently publicly documented and the EPSS score is not available. The vulnerability is not listed in the CISA KEV catalog, suggesting it has not yet been widely observed in the wild. The likely attack vector is authenticated but remote, requiring an attacker to supply malformed GeoJSON or geofence identifiers through an interface that accepts user data. Protection against exploitation hinges on input validation or library updates.

Generated by OpenCVE AI on November 3, 2026 at 21:06 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the maplibre-gl-js-amplify library to version 4.0.3 or newer.
  • Sanitize all user‑supplied fields (title, address, place_name, geofenceId) before they are rendered by popupRender or AmplifyGeofenceControl, ensuring that any embedded script or HTML is escaped or removed.
  • Enforce strict authentication and authorization controls so that only trusted users can submit or modify GeoJSON feature data or geofence identifiers, reducing the surface for malicious content injection.

Generated by OpenCVE AI on November 3, 2026 at 21:06 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Tue, 03 Nov 2026 20:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Tue, 03 Nov 2026 19:00:00 +0000

Type Values Removed Values Added
Description Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
Title Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering
First Time appeared Aws
Aws maplibre-gl-js-amplify
Weaknesses CWE-79
CPEs cpe:2.3:a:aws:maplibre-gl-js-amplify:*:*:*:*:*:*:*:*
Vendors & Products Aws
Aws maplibre-gl-js-amplify
References
Metrics cvssV3_1

{'score': 5.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N'}

cvssV4_0

{'score': 4.8, 'vector': 'CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N'}


Subscriptions

Aws Maplibre-gl-js-amplify
cve-icon MITRE

Status: PUBLISHED

Assigner: AMZN

Published:

Updated: 2026-11-03T20:01:00.960Z

Reserved: 2026-11-03T18:17:51.751Z

Link: CVE-2026-121652

cve-icon Vulnrichment

Updated: 2026-11-03T20:00:54.283Z

cve-icon NVD

Status : Received

Published: 2026-11-03T19:18:05.363

Modified: 2026-11-03T20:18:13.460

Link: CVE-2026-121652

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-03T21:15:03Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')