Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Markus Wiesenhofer Contact Form 7 – Post Fields cf7-post-fields allows Stored XSS.This issue affects Contact Form 7 – Post Fields: from n/a through 2.6.0.
Published: 2026-11-07
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch
AI Analysis

Impact

This CVE describes a stored XSS flaw arising from insufficient input sanitization in the Contact Form 7 – Post Fields plugin. An attacker who can insert arbitrary values into the plugin’s post fields may cause web pages to render malicious scripts. The resulting compromise can lead to session hijacking, cookie theft, or defacement of pages viewed by legitimate users, affecting confidentiality, integrity, and availability of the site.

Affected Systems

WordPress installations that have the Contact Form 7 – Post Fields plugin version 2.6.0 or earlier are vulnerable. The plugin is distributed by Markus Wiesenhofer through the WordPress plugin repository and is commonly used in sites that rely on Contact Form 7 for form handling. No other vendors or products are listed as affected.

Risk and Exploitability

The CVSS score is 6.5, indicating a medium–high severity. EPSS data is not available, so exploitation probability cannot be quantified. The vulnerability is not present in CISA’s KEV catalog. Attackers likely exploit the flaw by submitting crafted data through the form interface, which the plugin stores and later injects into web pages without proper escaping. The attack requires only the ability to submit form data, which is typically accessible to anyone who can reach the form.

Generated by OpenCVE AI on November 7, 2026 at 11:31 UTC.

Remediation

Vendor Solution

Update the WordPress Contact Form 7 – Post Fields plugin to the latest available version (at least 2.7.1).


OpenCVE Recommended Actions

  • Update the Contact Form 7 – Post Fields plugin to version 2.7.1 or newer as issued by the vendor.
  • If the Post Fields feature is not required, disable or remove the plugin to eliminate the vulnerable component.
  • Configure a content security policy (CSP) or a web application firewall (WAF) to block malicious scripts in the plugin’s output until the patch is applied.

Generated by OpenCVE AI on November 7, 2026 at 11:31 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 09:15:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Markus Wiesenhofer Contact Form 7 – Post Fields cf7-post-fields allows Stored XSS.This issue affects Contact Form 7 – Post Fields: from n/a through 2.6.0.
Title WordPress Contact Form 7 &#8211; Post Fields plugin <= 2.6.0 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T09:07:28.271Z

Reserved: 2026-11-04T00:24:30.154Z

Link: CVE-2026-121768

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T09:17:13.980

Modified: 2026-11-07T09:17:14.117

Link: CVE-2026-121768

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T11:45:07Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')