Description
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in YITH YITH WooCommerce Subscription yith-woocommerce-subscription allows Retrieve Embedded Sensitive Data.This issue affects YITH WooCommerce Subscription: from n/a through 4.22.0.
Published: 2026-11-07
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Sensitive Data Exposure
Action: Patch
AI Analysis

Impact

This vulnerability allows the YITH WooCommerce Subscription plugin to reveal embedded sensitive data that should remain confidential. The weakness is a case of insecure data handling, classified as CWE-497, where sensitive system information is improperly exposed to unauthorized parties.

Affected Systems

The affected product is the YITH WooCommerce Subscription plugin for WordPress, any release from the earliest version up to and including version 4.22.0. All WordPress sites that have this plugin installed and have not yet upgraded to a version later than 4.22.0 are potentially vulnerable.

Risk and Exploitability

The CVSS score of 5.3 indicates a moderate severity. No EPSS score is publicly available, and the vulnerability is not listed in CISA's KEV catalog. Attackers could exploit this flaw by accessing plugin-provided data or endpoints that expose sensitive information; while the exact attack vector is not specified, it is likely that the vulnerability can be triggered by users interacting with the plugin's interface, potentially without authentication. The vulnerability can be leveraged to compromise confidentiality of system or customer data.

Generated by OpenCVE AI on November 7, 2026 at 10:33 UTC.

Remediation

Vendor Solution

Update the WordPress YITH WooCommerce Subscription plugin to the latest available version (at least 4.23.0).


OpenCVE Recommended Actions

  • Upgrade the plugin to version 4.23.0 or later. 
  • If immediate upgrade is not possible, deactivate or restrict access to the plugin until the patch is applied. 
  • Regularly audit plugin usage and monitor site logs for unauthorized access attempts to sensitive data.

Generated by OpenCVE AI on November 7, 2026 at 10:33 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 09:00:00 +0000

Type Values Removed Values Added
Description Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in YITH YITH WooCommerce Subscription yith-woocommerce-subscription allows Retrieve Embedded Sensitive Data.This issue affects YITH WooCommerce Subscription: from n/a through 4.22.0.
Title WordPress YITH WooCommerce Subscription plugin <= 4.22.0 - Sensitive Data Exposure vulnerability
Weaknesses CWE-497
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T08:44:10.531Z

Reserved: 2026-11-04T00:24:30.155Z

Link: CVE-2026-121779

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T09:17:14.333

Modified: 2026-11-07T09:17:14.480

Link: CVE-2026-121779

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T10:45:09Z

Weaknesses
  • CWE-497

    Exposure of Sensitive System Information to an Unauthorized Control Sphere