Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Magepeople inc. WpBookingly service-booking-manager allows Stored XSS.This issue affects WpBookingly: from n/a through 1.4.3.
Published: 2026-11-07
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting allowing attacker‑injected scripts to run in the browsers of users who view the affected pages.
Action: Immediate Patch
AI Analysis

Impact

The vulnerability is a stored Cross‑Site Scripting flaw caused by improper neutralization of user input during web page generation. When an attacker submits malicious input that is persisted by the WpBookingly service‑booking‑manager, the input is rendered on subsequent page loads without sufficient escaping, enabling the attacker to execute arbitrary JavaScript in the context of the website as viewed by other users. This can lead to session hijacking, credential theft, defacement or the execution of additional malicious payloads. The flaw is classified as CWE‑79 and scores a moderate CVSS of 6.5.

Affected Systems

The issue affects the WordPress WpBookingly plugin (service‑booking‑manager) provided by Magepeople inc. All versions up to and including 1.4.3 are vulnerable. No higher versions are known to be affected.

Risk and Exploitability

A moderate CVSS score of 6.5 indicates that exploitation would provide the attacker with significant impact if the plugin is exposed to user input. The EPSS score is not available, and the vulnerability is not listed in the CISA KEV catalog, suggesting that it has not yet been confirmed as widely exploited. The most likely attack vector involves creating or editing a resource through the plugin’s input fields, which then stores the malicious payload and serves it to other visitors. Because the flaw is stored, the attacker does not need to maintain a continuous connection to inject payloads, making the exploitation straightforward once an entry is created.

Generated by OpenCVE AI on November 7, 2026 at 13:24 UTC.

Remediation

Vendor Solution

Update the WordPress WpBookingly plugin to the latest available version (at least 1.4.4).


OpenCVE Recommended Actions

  • Update the WpBookingly plugin to version 1.4.4 or newer, which eliminates the stored XSS flaw.
  • If the plugin is not required, uninstall it entirely to remove the vulnerability surface.
  • Review existing booking data and custom fields for any injected scripts and cleanse or delete them to prevent residual XSS execution.

Generated by OpenCVE AI on November 7, 2026 at 13:24 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 12:45:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Magepeople inc. WpBookingly service-booking-manager allows Stored XSS.This issue affects WpBookingly: from n/a through 1.4.3.
Title WordPress WpBookingly plugin <= 1.4.3 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T12:33:22.315Z

Reserved: 2026-11-04T00:24:30.155Z

Link: CVE-2026-121784

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T13:16:35.920

Modified: 2026-11-07T13:16:36.030

Link: CVE-2026-121784

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T13:30:12Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')