Description
The WP ImageViewer plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'img.alt' parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires a front-end content plugin such as bbPress to be active, as it grants Subscriber-level users the bbp_participant capability needed to publish image-bearing content containing the encoded payload. Exploitation by attackers with contributor-level access and above requires that the site allows Contributors (or higher) to submit image HTML in post content — the WordPress default. On a default installation, where that is not configured, the vulnerability requires attackers with custom-level access and above.
Published: 2026-11-07
Score: 6.4 Medium
EPSS: n/a
KEV: No
Impact: Stored DOM-based Cross-Site Scripting
Action: Apply Patch
AI Analysis

Impact

The WP ImageViewer plugin contains a stored DOM‑based XSS flaw that occurs when the alt attribute of an image is populated with unsanitized input. Because the plugin fails to escape the value before rendering, an attacker who can create or edit image content can embed arbitrary JavaScript that will run in the context of any visitor who loads the affected page. The attack requires authenticated access with Subscriber privileges or higher, and depends on the presence of a front‑end content plugin (e.g. bbPress) that grants the Subscriber role the bbp_participant capability.

Affected Systems

Any WordPress site that has the WP ImageViewer plugin installed, versions 3.0.2 or older, is affected. The vulnerability is active whenever the plugin is activated and an alt attribute value is stored in the WordPress database. Attackers with Contributor or higher privileges can also exploit the flaw on sites that allow image HTML in post content, which is enabled by default in WordPress. Sites that restrict such submission to custom roles must still consider that role or higher can contain the payload.

Risk and Exploitability

The flaw carries a CVSS score of 6.4, indicating moderate severity. EPSS data is not available, and the issue is not listed in the CISA KEV catalog. Exploitation is limited to authenticated users, and requires that the target site allows content submission with image tags or that a compatible front‑end plugin is installed. Once an injection is recorded, any user who views the page will have the attacker‑supplied script executed in their browser, potentially enabling session hijacking, credential theft, or further site compromise.

Generated by OpenCVE AI on November 7, 2026 at 12:38 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade WP ImageViewer to the latest version, 3.0.3 or later, which removes the unsanitized alt handling.
  • Remove or disable any front‑end posting plugins such as bbPress that grant subscribers the bbp_participant capability, or otherwise revoke that capability from the Subscriber role.
  • If an upgrade cannot be performed immediately, add a content sanitization layer that removes or escapes any script tags from the img.alt field before it is stored or rendered, or implement a strict content security policy that blocks inline scripts originating from user content.

Generated by OpenCVE AI on November 7, 2026 at 12:38 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The WP ImageViewer plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'img.alt' parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires a front-end content plugin such as bbPress to be active, as it grants Subscriber-level users the bbp_participant capability needed to publish image-bearing content containing the encoded payload. Exploitation by attackers with contributor-level access and above requires that the site allows Contributors (or higher) to submit image HTML in post content — the WordPress default. On a default installation, where that is not configured, the vulnerability requires attackers with custom-level access and above.
Title WP ImageViewer <= 3.0.2 - Authenticated (Subscriber+) Stored DOM-Based Cross-Site Scripting via Image 'alt' Attribute
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.4, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T18:06:01.533Z

Reserved: 2026-11-04T16:39:48.805Z

Link: CVE-2026-122059

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T12:17:45.607

Modified: 2026-11-07T18:17:20.347

Link: CVE-2026-122059

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T12:45:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')