Description
The Church Admin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lat' parameter in all versions up to, and including, 5.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when a Google Maps API key has been configured in Church Admin settings, as the vulnerable sink is only reached when that option is present.
Published: 2026-11-07
Score: 7.2 High
EPSS: n/a
KEV: No
Impact: Stored Cross‑Site Scripting
Action: Patch Immediately
AI Analysis

Impact

The Church Admin plugin for WordPress contains a stored Cross‑Site Scripting flaw that is triggered when an unauthenticated user supplies the "lat" parameter. Because the plugin does not properly sanitize or escape this value, arbitrary scripts can be persisted and executed whenever a victim renders a page that includes the injected content. The issue is only reachable if a Google Maps API key is configured, which activates the vulnerable code path.

Affected Systems

WordPress installations running the Church Admin plugin version 5.1.7 or earlier, and any sites that have not upgraded beyond those releases. The vendor is Andy Moyle and the affected product is the Church Admin WordPress plugin.

Risk and Exploitability

The CVSS score of 7.2 classifies the vulnerability as high severity. EPSS information is not available, and the flaw is not listed in the CISA KEV catalog, suggesting lower public exploitation prevalence. Based on the description, the likely attack vector is an unauthenticated request to the plugin’s endpoint that accepts the "lat" parameter, possibly during site administration or content creation. Once exploited, an attacker can execute arbitrary JavaScript in the context of any user who visits the affected page, leading to theft of session data or malicious actions performed without the user’s knowledge.

Generated by OpenCVE AI on November 7, 2026 at 12:36 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Church Admin plugin to version 5.1.8 or later, which removes the vulnerable code.
  • If an upgrade cannot be performed immediately, disable the Google Maps API key setting in Church Admin to eliminate the code path that processes the "lat" parameter.
  • As a short‑term defense, apply server‑side validation or sanitization to the "lat" query parameter, ensuring only valid numeric latitude values are accepted before any output is rendered.

Generated by OpenCVE AI on November 7, 2026 at 12:36 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 08 Nov 2026 06:30:00 +0000

Type Values Removed Values Added
Metrics ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'partial'}, 'version': '2.0.3'}


Sat, 07 Nov 2026 11:30:00 +0000

Type Values Removed Values Added
Description The Church Admin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lat' parameter in all versions up to, and including, 5.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when a Google Maps API key has been configured in Church Admin settings, as the vulnerable sink is only reached when that option is present.
Title Church Admin <= 5.1.7 - Unauthenticated Stored Cross-Site Scripting via 'lat' Parameter
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 7.2, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-11-07T18:06:00.083Z

Reserved: 2026-11-05T22:05:12.591Z

Link: CVE-2026-123418

cve-icon Vulnrichment

Updated: 2026-11-07T17:59:30.541Z

cve-icon NVD

Status : Deferred

Published: 2026-11-07T12:17:45.933

Modified: 2026-11-07T18:17:20.697

Link: CVE-2026-123418

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T12:45:14Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')