Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liquid Web / StellarWP The Events Calendar the-events-calendar allows Stored XSS.This issue affects The Events Calendar: from n/a through 6.18.3.
Published: 2026-11-07
Score: 6.5 Medium
EPSS: n/a
KEV: No
Impact: Cross-site scripting (XSS) allows arbitrary script execution in the context of site visitors
Action: Patch Now
AI Analysis

Impact

The vulnerability is an improper neutralization of input during web page generation that allows attackers to store malicious scripts in event data. When the event information is displayed on the site, the injected scripts run in visitors' browsers, potentially stealing session cookies, defacing content, or redirecting users to malicious pages. The weakness is classified as CWE‑79 and provides only client‑side damage without server‑side code execution.

Affected Systems

The flaw affects WordPress The Events Calendar plugin versions up through 6.18.3. Site owners running any of those releases—at no minimum any version prior to 6.18.3.1—are vulnerable. The plugin is distributed by Liquid Web and StellarWP and is a common addition to WordPress installations that manage event listings.

Risk and Exploitability

The CVSS base score is 6.5, indicating moderate severity. No EPSS score is published, so the real‑world exploitation probability is unknown, and the vulnerability has not been listed in CISA’s KEV catalog. Attackers likely need write access to event content or the ability to create an event; a privileged user can inject scripts that persist in the database. Once injected, any visitor who views the event will have the malicious code executed, yielding client‑side impact.

Generated by OpenCVE AI on November 7, 2026 at 10:35 UTC.

Remediation

Vendor Solution

Update the WordPress The Events Calendar plugin to the latest available version (at least 6.18.3.1).


OpenCVE Recommended Actions

  • Update the WordPress The Events Calendar plugin to version 6.18.3.1 or later, the vendor‑provided fix for this XSS flaw.
  • If the update cannot be applied immediately, restrict the ability to create or edit event content to trusted administrators only, preventing untrusted users from injecting malicious scripts.
  • Perform a review of existing event entries for harmful script tags and purge any malicious code to eliminate residual stored XSS vulnerabilities.

Generated by OpenCVE AI on November 7, 2026 at 10:35 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 09:30:00 +0000

Type Values Removed Values Added
Description Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liquid Web / StellarWP The Events Calendar the-events-calendar allows Stored XSS.This issue affects The Events Calendar: from n/a through 6.18.3.
Title WordPress The Events Calendar plugin <= 6.18.3 - Cross Site Scripting (XSS) vulnerability
Weaknesses CWE-79
References
Metrics cvssV3_1

{'score': 6.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Patchstack

Published:

Updated: 2026-11-07T09:15:20.726Z

Reserved: 2026-11-06T00:25:34.012Z

Link: CVE-2026-123464

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-11-07T10:17:11.603

Modified: 2026-11-07T10:17:11.733

Link: CVE-2026-123464

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T10:45:09Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')