Description
The Post Snippets WordPress plugin through 4.2.4 does not properly escape variable values substituted into snippets before outputting them, allowing users with the Contributor role and above to inject arbitrary web scripts that execute when the content is viewed.
Published: 2026-10-11
Score: 6.8 Medium
EPSS: < 1% Very Low
KEV: No
Impact: Stored Cross‑Site Scripting via unsanitized snippet variables
Action: Immediate Patch
AI Analysis

Impact

The Post Snippets plugin for WordPress up to version 4.2.4 does not properly escape variable values that are users with a Contributor role or higher to inject arbitrary JavaScript that is executed in the browsers of any visitor who opens a page containing the snippet. The stored cross‑site scripting can lead to theft of session cookies, defacement, or the execution of malicious actions on behalf of the site’s users.

Affected Systems

All WordPress sites running the Post Snippets plugin version 4.2.4 or earlier are affected, regardless of the site’s theme or other plugins. The vulnerability is tied to the plugin’s snippet editing and rendering functions, so any site that uses this plugin to generate content is vulnerable.

Risk and Exploitability

The CVSS score of 6.8 classifies this flaw as medium severity. The EPSS score of 0.00163 indicates an extremely low probability of exploitation, and the vulnerability is not listed in the CISA KEV catalog. Nonetheless, the flaw remains substantial from a practical standpoint because it only requires a logged‑in Contributor or higher user and no additional privileges; the exploit is straightforward and does not need external network access. An attacker who can access the snippet editor can embed malicious code that will then run in the context of all visitors to pages using the snippet. The lack of a public exploit or known wide‑scale attacks suggests the probability of exploitation is very low, but the impact remains significant should an attacker leverage the vulnerability.

Generated by OpenCVE AI on October 11, 2026 at 16:05 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Update the Post Snippets plugin to a verified version newer than 4.2.4 where variable escaping is fixed.
  • If an update is not immediately possible, remove the Contributor (or any role that can create snippets) capability to add or edit snippets using role‑management plugins or custom code.
  • Disable or uninstall the Post Snippets plugin entirely until a secure version is released or an alternative solution is adopted.

Generated by OpenCVE AI on October 11, 2026 at 16:05 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sun, 11 Oct 2026 12:30:00 +0000

Type Values Removed Values Added
Metrics cvssV3_1

{'score': 6.8, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H'}

ssvc

{'options': {'Automatable': 'no', 'Exploitation': 'none', 'Technical Impact': 'total'}, 'version': '2.0.3'}


Sun, 11 Oct 2026 08:00:00 +0000

Type Values Removed Values Added
Weaknesses CWE-79

Sun, 11 Oct 2026 06:30:00 +0000

Type Values Removed Values Added
Description The Post Snippets WordPress plugin through 4.2.4 does not properly escape variable values substituted into snippets before outputting them, allowing users with the Contributor role and above to inject arbitrary web scripts that execute when the content is viewed.
Title Post Snippets <= 4.2.4 - Contributor+ Stored XSS via Snippet Variable
References

Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: WPScan

Published:

Updated: 2026-10-11T11:42:54.023Z

Reserved: 2026-06-23T11:27:30.490Z

Link: CVE-2026-12980

cve-icon Vulnrichment

Updated: 2026-10-11T11:30:54.214Z

cve-icon NVD

Status : Deferred

Published: 2026-10-11T07:17:23.890

Modified: 2026-10-13T20:36:00.850

Link: CVE-2026-12980

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-11T16:15:17Z

Weaknesses
  • CWE-79

    Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')