Description
The Product Designer for WooCommerce WordPress | Lumise plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.1.2 via the process_checkout function. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. The lumise_security nonce required to reach the vulnerable /?lumise=cart endpoint is freely obtainable by any unauthenticated visitor via the /?lumise=ajax action=init handler, making this exploitable with no prior access or credentials.
Published: 2026-10-28
Score: 7.5 High
EPSS: < 1% Very Low
KEV: No
Impact: Arbitrary File Read via Directory Traversal
Action: Immediate Patch
AI Analysis

Impact

The Lumise plugin for WordPress is vulnerable to a directory traversal flaw in the process_checkout function, allowing an attacker to construct a payload that reads the contents of any file on the server. Attackers can supply a specially crafted design.stages[*].image parameter in the cart JSON upload, causing the plugin to process the path and expose file data. This flaw enables unauthenticated disclosure of sensitive files, such as configuration files or credentials, which can compromise the confidentiality and integrity of the entire WordPress installation.

Affected Systems

The vulnerability affects the King-Theme Product Designer for WooCommerce WordPress—Lumise plugin, all versions up to and including 2.1.2. Any site that has installed this plugin without upgrading to a newer version is at risk.

Risk and Exploitability

The CVSS score of 7.5 indicates a high severity for information disclosure. Although no EPSS data is available, the exploit requires no prior authentication; any user can retrieve a nonce via the /?lumise=ajax action=init handler and then invoke the vulnerable /?lumise=cart endpoint with a crafted path. The vulnerability is not listed in the CISA KEV catalog, but its remote, unauthenticated nature and the ability to read arbitrary files make it a significant risk if exploited.

Generated by OpenCVE AI on October 28, 2026 at 06:50 UTC.

Remediation

No solution or workaround provided in the CVE record.

OpenCVE Recommended Actions

  • Upgrade the Lumise plugin to version 2.1.3 or later, which removes the process_checkout directory traversal flaw.
  • If upgrading is not immediately possible, block or restrict access to the /?lumise=cart endpoint, for example by adding authentication requirements or IP whitelisting so that trusted users can reach it.
  • If the plugin is not essential to the site, disable or uninstall Lumise completely to eliminate the attack surface.

Generated by OpenCVE AI on October 28, 2026 at 06:50 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Wed, 28 Oct 2026 05:45:00 +0000

Type Values Removed Values Added
Description The Product Designer for WooCommerce WordPress | Lumise plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.1.2 via the process_checkout function. This makes it possible for unauthenticated attackers to read the contents of arbitrary files on the server, which can contain sensitive information. The lumise_security nonce required to reach the vulnerable /?lumise=cart endpoint is freely obtainable by any unauthenticated visitor via the /?lumise=ajax action=init handler, making this exploitable with no prior access or credentials.
Title Product Designer for WooCommerce WordPress | Lumise <= 2.1.2 - Unauthenticated Arbitrary File Read via 'design.stages[*].image' Parameter in Cart JSON Upload
Weaknesses CWE-22
References
Metrics cvssV3_1

{'score': 7.5, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N'}


Subscriptions

No data.

cve-icon MITRE

Status: PUBLISHED

Assigner: Wordfence

Published:

Updated: 2026-10-28T05:33:31.729Z

Reserved: 2026-07-09T18:14:33.944Z

Link: CVE-2026-15323

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Deferred

Published: 2026-10-28T06:16:36.043

Modified: 2026-10-28T13:46:33.207

Link: CVE-2026-15323

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-10-28T07:00:11Z

Weaknesses
  • CWE-22

    Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')