Impact
The vulnerability is a confused deputy issue that allows a remote authenticated attacker to bypass security restrictions, granting unauthorized access and potential privilege escalation within IBM API Connect. It represents a high-impact flaw as indicated by the CVSS score of 9.9.
Affected Systems
IBM API Connect versions 12.1.0.0 through 12.1.1.2 are vulnerable.
Risk and Exploitability
The CVSS score of 9.9 indicates a critical risk, while no EPSS score is available so current exploitation probability is unknown. The vulnerability is not listed in the CISA KEV catalog. The likely attack vector is a remote authenticated user. The flaw arises from a confused‑deputy authorization logic, allowing a logged‑in attacker to override security restrictions and access resources or perform actions beyond their intended scope. IBM recommends upgrading to v12.1.1.3 immediately to mitigate this risk.
OpenCVE Enrichment