Description
IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to verbose error messages.
Published: 2026-11-07
Score: 5.3 Medium
EPSS: n/a
KEV: No
Impact: Information disclosure through verbose error messages
Action: Apply patch
AI Analysis

Impact

The vulnerability allows a remote attacker to trigger requests that produce verbose error messages, revealing sensitive information such as system configuration or internal data. The impact is the exposure of confidential data that could be leveraged for more targeted attacks; however, it does not provide direct code execution or unauthorized access to system resources. The weakness is identified as CWE-209.

Affected Systems

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 are affected. This includes the product identifiers listed in the Common Platform Enumeration strings for IBM API Connect 10.0.8.0, 10.0.8.12, 12.1.0.0, and 12.1.1.2.

Risk and Exploitability

The CVSS score of 5.3 places the vulnerability in the moderate category, indicating a meaningful risk if not mitigated. The EPSS score is not available, so the current exploitation likelihood is uncertain. The vulnerability is not in the CISA Known Exploited Vulnerabilities catalog. Based on the description, it is inferred that the attack vector is remote, through the API Connect web or REST interface, whereby an attacker crafts a request that provokes a verbose error response.

Generated by OpenCVE AI on November 7, 2026 at 08:27 UTC.

Remediation

Vendor Solution

IBM strongly recommends addressing the vulnerability now by upgrading to v12.1.1.3 Fix Central Link: https://www.ibm.com/support/pages/node/7290205 IBM strongly recommends addressing the vulnerability now by upgrading to 10.0.8.13Fix Central Link: https://www.ibm.com/support/fixcentral/swg/selectFixes?parent=ibm%7EWebSphere&product=ibm/WebSphere/IBM+API+Connect&release=10.0.8.12&platform=All&function=all


OpenCVE Recommended Actions

  • Upgrade IBM API Connect to v12.1.1.3 (or v10.0.8.13) as per vendor recommendation.
  • Install the corresponding Fix Central update for your platform from the IBM Fix Central link.
  • Configure the API Connect environment to suppress or limit verbose error messages to reduce information disclosure until the patch is applied.

Generated by OpenCVE AI on November 7, 2026 at 08:27 UTC.

Tracking

Sign in to view the affected projects.

Advisories

No advisories yet.

History

Sat, 07 Nov 2026 04:45:00 +0000

Type Values Removed Values Added
Description IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote attacker to obtain sensitive information due to verbose error messages.
Title Multiple Vulnerabilities in IBM API Connect
First Time appeared Ibm
Ibm api Connect
Weaknesses CWE-209
CPEs cpe:2.3:a:ibm:api_connect:10.0.8.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:10.0.8.12:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:12.1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:api_connect:12.1.1.2:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm api Connect
References
Metrics cvssV3_1

{'score': 5.3, 'vector': 'CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N'}


cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-07T04:31:45.252Z

Reserved: 2026-07-24T15:06:29.449Z

Link: CVE-2026-17098

cve-icon Vulnrichment

No data.

cve-icon NVD

Status : Awaiting Analysis

Published: 2026-11-07T05:18:24.493

Modified: 2026-11-07T05:18:24.703

Link: CVE-2026-17098

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

Updated: 2026-11-07T11:15:15Z

Weaknesses
  • CWE-209

    Generation of Error Message Containing Sensitive Information